VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Flash 10.2.152.27 or 10.1.53.64? [SOLVED]  (Read 2076 times)

RonB

  • Vectorite
  • ***
  • Posts: 120
Flash 10.2.152.27 or 10.1.53.64? [SOLVED]
« on: February 19, 2011, 03:11:01 pm »

This is the first time something like this has happened. I delayed updating Flash because, for a while, the newest releases crashed when you went to full screen in Hulu or Youtube. It appears that's been fixed -- the newest version worked in CentOS 5.5 and Linux Mint 10 (which I'm testing for my Dad). So I decided it was "safe" install for VectorLinux. So I just followed OpenSource Bistro instructions as usual (download the Flash package, opened it up and copied the libflashplayer.so file into /usr/lib/mozilla/plugins). I think I have the correct update -- it shows the exact same size as the libflashplayer.so in CentOS (which came from CentOS repositories) so I can't see how Firefox could be using anything else in VectorLinux. But when when I go to Adobe's site is still shows 10,1,53,64 instead of 10,2,152,27 as the version. When I go to add-ons in Firefox, I see both versions of Flash enabled (which doesn't make sense to me). So, I'm guessing, that I do have the correct version of Flash installed, but Firefox is not reporting it correctly. Has anyone ever ran into something like this?   

Okay, I found the problem. Again, literally, right after posting. (This is beginning to freak me out. The mere process of posting in the VectorLinux forums has some magical power to supply the answers and fix problems.) Because I didn't trust the new Flash update, I renamed the old one in the directory, but left it there. Apparently some kind of link remained, even though the name had changed? (Maybe someone can explain how this works?) At any rate, within the /usr/lib/mozilla/plugins directory, I made an "old" directory and moved the old, renamed "libflashplayer.so" file to that. Once I did that, I started Firefox, it reported the correct version of Flash and only the new version appears in the "add-ons" within Firefox. And it definitely works correctly now with Hulu and Youtube. Now I won't be harassed by Firefox to update to the newest Flash all the time.

All thanks to the magical powers of the act of posting in the VectorLinux forum.
« Last Edit: February 19, 2011, 03:27:12 pm by RonB »
Logged
RonB
Registered Linux User #498581
Vector Linux Deluxe 6.0 -- Optiplex GX270