Author Topic: Can't access nfs share since server upgraded to nfsv4 [solved]  (Read 3097 times)


  • Member
  • *
  • Posts: 55
Can't access nfs share since server upgraded to nfsv4 [solved]
« on: February 04, 2011, 04:45:19 am »

I have an nfs share on a ubuntu server and I could access this from Vector 6 as the client without any problems. Recently, ubuntu upgraded to the nfs-kernel-server package which is nfsv4 and I cannot access the share.

The ubuntu documentation states that I need an idmapd daemon on the client? I have to admit the nfs documentation by ubuntu and debian is a little confusing and I'm not sure what the state of nfsv4 access on Vector is.

Thanks for any advice.

Solution: I could not get nfsv4 working with Vector 6 SG as client. Nfs4 is built into the Vector kernel- 'fgrep nfs4 /proc/kallsyms' shows that.

Nfsv4 requires extra security provided by idmapd, part of nfs-utils, /etc/idmapd.conf needs to be configured on the client. No big deal though it works fine with nfs3, or just recompile nfs-utils if you need nfs4.
« Last Edit: February 06, 2011, 12:44:28 pm by davidlondonuk »