VectorLinux
October 01, 2014, 08:04:29 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Internet ConnectionProblems under VL5.9 & VL6.0  (Read 3912 times)
Martin109
Vectorite
***
Posts: 290


« on: February 09, 2011, 05:34:49 am »

My PlusNet broadband is suddenly not working with my two Linux machines, one running VL5.9 and connecting with an ethernet cable, the other running VL6.0 and connecting wirelessly; both have been working fine, but not now.

I can connect to my Netgear router admin page, and the router is connected. But it won't connect to my homepage or any other standard URL.

PlusNet support asked me to connect to 212.159.8.2 and it then (slowly) connects to the PlusNet site.  Support say that the computers should be connecting specifically to 212.159.13.49 (Primary) or 212.159.13.50 (Secondary), under DNS settings, rather than automatically.

I can connect with my Windoze machine (spit!), having set the DNS parameters as above, but I don't know how to do this under 5.9 and 6.0.

What do I need to change and where in order to connect specifically as above under DNS?
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
newt
Vectorian
****
Posts: 1132



« Reply #1 on: February 09, 2011, 07:56:32 am »

/etc/resolv.conf would be the file where you specify your DNS nameservers

Example contents of /etc/resolv.conf:
nameserver 212.159.13.49
nameserver 212.159.13.50
Logged
Martin109
Vectorite
***
Posts: 290


« Reply #2 on: February 09, 2011, 02:39:44 pm »

Thanks, newt.  I've tried the following:

VL5.9 (wired connection)

3 files found in /etc

resolv.conf
resolv.conf-eth0.sv
resolv.conf-ath0.sv

I backed up the first two, which had the following:

nameserver 212.135.1.36
nameserver 195.40.1.36

then changed the lines to:

nameserver 212.195.13.49
nameserver 212.195.13.50

and rebooted.  No change.  Still not finding my homepage.  When I examined the files again, resolv.conf had been changed back to its original lines, whereas resolv.conf-eth0.sv was unchanged.


VL6.0 (wireless connection)

2 files found in /etc

resolv.conf
resolv.conf-wlan0.sv

I backed them up, and they read as follows:

nameserver 212.135.1.36
nameserver 195.40.1.36

then changed the lines to:

nameserver 212.195.13.49
nameserver 212.195.13.50

and rebooted.  No change.  Still not finding my homepage.  When I examined the files again, resolv.conf had been changed back to its original lines, whereas resolv.conf-wlan0.sv was unchanged.

Some part of the system is rewriting the files, obviously.



Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
newt
Vectorian
****
Posts: 1132



« Reply #3 on: February 09, 2011, 02:52:00 pm »

Assuming you use dhcp for your network connection, it looks like you will need to manually edit your /etc/rc/rc.inet1 script and add the '-R' option to the lines invoking '/sbin/dhcpcd' in order to prevent resolv.conf from being overwritten.  After a reboot you will likely need to re-create the resolv.conf file with the nameservers that have been recommended to you.
Logged
Martin109
Vectorite
***
Posts: 290


« Reply #4 on: February 10, 2011, 07:33:39 am »

Thanks again, newt.

I shall not be back to these machines until next Monday, when I shall try out what you outline.  Many thanks.
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Martin109
Vectorite
***
Posts: 290


« Reply #5 on: February 14, 2011, 01:17:31 pm »

Assuming you use dhcp for your network connection, it looks like you will need to manually edit your /etc/rc/rc.inet1 script and add the '-R' option to the lines invoking '/sbin/dhcpcd' in order to prevent resolv.conf from being overwritten.  After a reboot you will likely need to re-create the resolv.conf file with the nameservers that have been recommended to you.

I do not find on either system (5.9 or 6.0) anything which is precisely the same as what you state.

I do not have /etc/rd/rc.inet1, but I do have /etc/rc.d/inet1.conf

In that file settings for eth0[0], eth1[1], eth2[2] & eth3[3] are made, each with the line:
IPADDR[0/1/2/3]=””

Also, suggestions are made for settings to a wireless connection wlan0[4], including the lines:

#IPADDR[4]=””

and

#DHCP_IPADDR[4]=””   # Request a specific IP address from the DHCP
                          # server


I don't want to make any changes where I don't understand what I'm doing, so I await further assistance.

The most puzzling thing is why these machines were working fine one week, then not the next, when nothing had been changed! Undecided
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
newt
Vectorian
****
Posts: 1132



« Reply #6 on: February 15, 2011, 07:34:31 am »

Does that config file (/etc/rc.d/inet1.conf) look to contain your connection settings for your network?  If so, then adding the following line just below USE_DHCP should instruct your system to keep the current resolv.conf:

DHCP_KEEPRESOLV[4]="yes"
Logged
Martin109
Vectorite
***
Posts: 290


« Reply #7 on: February 17, 2011, 05:56:33 am »

Thanks, newt.  That seems to have worked with the wirelessly connected machine.  I'll try it out now with the wired connection.
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
MacyMoore
Member
*
Posts: 1



« Reply #8 on: May 05, 2011, 04:05:25 am »

I can't connect to the internet when I am using the USB cable to my computer. What do I need to do to enable IE?
Logged

Martin109
Vectorite
***
Posts: 290


« Reply #9 on: May 05, 2011, 06:45:15 am »

Hi MacyMoore

You may find you get a quicker response if you start a new thread about this problem; it's easy for a new query like yours to get lost and overlooked when tacked on to the end of a previous thread.

You also mention IE, which usually stands for Internet Explorer, a Micro$haft Windoze program!  Do you mean that, or are you referring to your Browser which, under Vector Linux, is more likely to be Firefox, Opera, Seamonkey etc?

Can you connect to your router using its numeric address (eg 192.168.0.1, though this may not be right for yours)?

Good luck!
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!