VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: 1 ... 5 6 [7] 8

Author Topic: VectorLinux 7 Beta2 bugs and observations  (Read 42498 times)

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #90 on: April 20, 2011, 12:29:05 pm »

Quote
Sorry to be the bringer of bad news and all that but you did ask for problems! Also, a couple of apps I've come to rely on in Vector are apparently no longer present; Chestnut Dialer for PPP dialup, and K3B for burning data and ISOs to CD and DVD. Is this intentional?

Chestnut dialer is in the testing repo, (you will need to enable it on a fresh install) and k3b is in the works.

If you want k3b now and 70 other applications, you could try the MMBD for vl7.0
http://www.opensourcebistro.com/catalog/product_info.php?products_id=30&osCsid=ccb591d06058b985f37d1adfa97e7050
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

Colonel Panic

  • Vectorian
  • ****
  • Posts: 526
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #91 on: April 21, 2011, 09:17:09 am »

Thanks for your reply and the info,

CP .
Logged

Pita

  • Vectorian
  • ****
  • Posts: 1342
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #92 on: April 24, 2011, 08:15:52 pm »

Floppy cannot be mounted since there is no /dev/fd0:

@~:$ mount /mnt/floppy
mount: special device /dev/fd0 does not exist

l$ ls /dev/f*         
/dev/fb0  /dev/full  /dev/fuse

Further: category LC_ALL is not supported. That is for Zeroinstall of Rox.

Logged

sledgehammer

  • Vectorian
  • ****
  • Posts: 1484
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #93 on: April 27, 2011, 10:33:45 pm »

Well, I bought a Samsung 511, the only laptop I could find with a sunlight readable lcd (I couldn't find a lenovo laptop with a sunlight readable screen). 

VL 6.0 would not load. It either didn't find the media or didn't find the hard-drive, depending on whether I used the regular or the old installer (linux).  So I tried VL 7 Beta 2 and it loaded fine with the modern installer, but WICD did not find the wireless card.  So, figuring my computer might not have a working wireless card in it (though the box said otherwise) I loaded mint and the wireless worked flawlessly.  So I then tried VL 7 Beta 2 with the old installer (install) and it loaded fine but did not install xfce4 and wicd (via fluxbox) could not find any wireless extensions. Ifconfig didn't show any wireless at all.  That is where I am now.

Does anyone have a suggestion on how I can access the wireless card?  I'm sure mint is fine and all that but don't want to fool with a new operating system.

I am going to hook it up to the wire now and update everything.  I will report if that works.

john
Logged
VL7.0 xfce4 Samsung RF511

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #94 on: April 27, 2011, 11:15:25 pm »

John,
Post the id of your wireless card.
it should be in the output of lspci or possibly lsusb

Logged

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #95 on: April 27, 2011, 11:16:35 pm »

I hope you installed VL7 beta 2.1 and not VL7 beta 2. Beta 2.1 fixed some fatal problems I had with beta 2.

Someone else will have to help with your wireless, since that's something I had to flail about with to get it working on my VL6 Light laptop, my only computer with wireless.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

j.a.watson

  • Member
  • *
  • Posts: 11
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #96 on: April 27, 2011, 11:47:34 pm »

Regarding the Samsung 511, although I am not familiar with that specific model I have two other Samsung netbooks (N150 and NF310), and I suspect that the 511 most likely has a Broadcom 4313 wireless adapter.  That requires the brcm80211 driver, which as far as I know is still not included in the VL7B2 distribution.

If it is any consolation, I have tested both of my Samsung sytems with a variety of other Linux distributions which do include the brcm80211 driver, and they work very well.  So hopefully all will be well once the driver makes it into VL.

While it is possible to get the 4313 adapter working with the older "wl" or "broadcom-wl" driver (aka "STA" on Ubuntu), there are serious performance problems with it, and the throughput very low.

jw
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #97 on: April 27, 2011, 11:55:37 pm »

@sledgehammer.  Just want you to check one thing. As of the more recent release 2.1 I believe amount them. WICD is not completely configured at install.
You may simply need to click the wicd icon on the panel, click preferences in that window then in the resulting window from that enter
wlan0         
in the Wireless interface box.

if that does not work try
wlan1
To find out for sure as root, in the terminal, type
iwconfig
If it gives you a wlan#, than use that.  If it does not give you a number for wlan then, indeed you have a different problem.
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

sledgehammer

  • Vectorian
  • ****
  • Posts: 1484
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #98 on: April 28, 2011, 07:36:25 am »

Thanks.   Got model wrong.  Its a Samsung RF511.  Nothing on iwconfig, Stretchedthin.  Yes, j.a.watson, everything but wireless seems to be working.  Not too sure though as I won't bother loading my programs and date til I get wireless working.  My son might do me a favor and load the driver.

john
Logged
VL7.0 xfce4 Samsung RF511

Andy Price

  • Packager
  • Vectorite
  • ****
  • Posts: 237
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #99 on: April 28, 2011, 08:24:35 am »

With development moving at a good pace I wonder how near VL7 is to freezing features? There are a few things I've noticed and would like to mention. Please forgive any repeats!

The text installer doesn't have an option to check the disk for integrity any more, nor does it allow you to choose which packages to install. It uses LILO by default and there's no option to install GRUB, unlike the GUI installer.

VASM has the option to save the user password but Gslapt, which I use much more, doesn't.

One other thought:
At present the GUI installer offers three options which are (roughly) "everything", "choose not to install some apps" and "minimal system plus X". I tried the latter and is was just a bit too stark (for me) and difficult to build upon. How about an option for "minimal install plus X plus XFCE base"? This would give a nice lean installation with an easy-to-use GUI, to which you could add your own choice of apps. It's not really my idea; I tried Salix recently and this was one of the installation options which I really liked. It's seems far preferable to removing all the stuff that you don't want.

Cheers
Andy
Logged

sledgehammer

  • Vectorian
  • ****
  • Posts: 1484
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #100 on: April 28, 2011, 09:01:34 am »

Quote
I hope you installed VL7 beta 2.1 and not VL7 beta 2. Beta 2.1 fixed some fatal problems I had with beta 2.

Grannygeek,

How do I know which version I installed?

Thanks

John
Logged
VL7.0 xfce4 Samsung RF511

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4140
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #101 on: April 28, 2011, 12:18:06 pm »

cat /etc/vector-version
Logged

j.a.watson

  • Member
  • *
  • Posts: 11
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #102 on: April 28, 2011, 01:01:11 pm »

One simple way to find out what kind of wireless adapter you have is "lspci" as root.  If you see "Broadcom 4313" in the list, that's what you have, and you need the brcm80211 driver.  If it is some other Broadcom model, or something else entirely (Atheros, Intel or some such), you might have a bit more luck.

jw
Logged

sledgehammer

  • Vectorian
  • ****
  • Posts: 1484
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #103 on: April 28, 2011, 09:49:18 pm »

I now have VL7 Beta 2.1 installed on the Samsung.  Still had trouble getting xfce4 to run.  Removed the installed xfce4, update and reinstall xfce4.

j.a.watson, I think this may be it (I am typing this on the T42 so am copying from the RF511 lspci)

02:00.0 Network controller:  Intel Corporation WiFi Link 1000 series

Not too sure where to go from here.

John

Logged
VL7.0 xfce4 Samsung RF511

j.a.watson

  • Member
  • *
  • Posts: 11
Re: VectorLinux 7 Beta2 bugs and observations
« Reply #104 on: April 29, 2011, 01:05:54 am »

Yes, that appears to be it.  I'm afraid I can't be of much more specific help here, because I don't have anything with that adapter in it.  From what I can find with a quick search, it should use the iwlagn driver, which is the same one that the Intel 5300 adapter in my Fujitsu laptop uses.  You can find out if the driver is being loaded with "lspci -v", if there is a driver attached to it it will be listed on the last line of information for that device.  It apparently also needs the firmware from the package "firmware-iwlwifi".  But even with that much information, I can't tell you clearly how to get it working, because I don't have one.  Hopefully someone more expert here that I can help you further.  Good luck.
Logged
Pages: 1 ... 5 6 [7] 8