Please support VectorLinux!

Author Topic: KDE-4.6.2 and it dependencies  (Read 9022 times)

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: KDE-4.6.2 and it dependencies
« Reply #15 on: April 24, 2011, 06:34:46 pm »
I think R will require gcc-gfortran to run...is gcc-gfortran available in the testing repo?

amigib

  • Member
  • *
  • Posts: 3
Re: KDE-4.6.2 and it dependencies
« Reply #16 on: April 26, 2011, 06:36:28 am »
Wondering why kded4 process is consuming 100% CPU (one core) on startup, can somebody confirm this issue?

Ok, downgrading ntrack from 014 to 013 solved problem for now.
« Last Edit: April 26, 2011, 03:36:01 pm by amigib »

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: KDE-4.6.2 and it dependencies
« Reply #17 on: April 26, 2011, 04:43:41 pm »
Wondering why kded4 process is consuming 100% CPU (one core) on startup, can somebody confirm this issue?

Ok, downgrading ntrack from 014 to 013 solved problem for now.

It take how long for the process to become normal?

vector

  • Administrator
  • Vectorite
  • *****
  • Posts: 479
Re: KDE-4.6.2 and it dependencies
« Reply #18 on: April 26, 2011, 06:38:23 pm »
Quote
Ok, downgrading ntrack from 014 to 013 solved problem for now.
I can confirm that by replacing ntrack 14 with ntrack 13 cpu usage took a huge drop from about 70% to less than 3%. Think we can file that as a bug...................... ;D

Cheers,
Vec

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: KDE-4.6.2 and it dependencies
« Reply #19 on: April 26, 2011, 06:45:50 pm »
It seem i cannot run gslapt from console anymore when using kde...

Quote
root:# gslapt
No protocol specified

(gslapt:2892): Gtk-WARNING **: cannot open display: :0.0

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: KDE-4.6.2 and it dependencies
« Reply #20 on: April 26, 2011, 08:05:46 pm »
I think R will require gcc-gfortran to run...is gcc-gfortran available in the testing repo?

Any idea to solve the gcc-gfortran issue?
Should it be include in the VL repo or make it as default in VL?

amigib

  • Member
  • *
  • Posts: 3
Re: KDE-4.6.2 and it dependencies
« Reply #21 on: April 27, 2011, 12:35:59 am »
Quote
It take how long for the process to become normal?

It never goes normal, as i know its ntrack bug

And i found problem with qca package, pkgconfig file is in wrong path so some programs (like kadu) can't find it
« Last Edit: April 27, 2011, 01:18:25 pm by amigib »

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: KDE-4.6.2 and it dependencies
« Reply #22 on: April 28, 2011, 12:47:24 am »
for those who having problem with jovie...pls install/upgrade to speech-dispatcher-0.7.1-i586-5vl70 and espeak.
then run spd-conf in console to setup the config file

stretchedthin: pls move the latest speech-dispatcher from my contrib folder to the repo. thanks.

for the ntrack issue... i have rebuild kdebase-runtime-4.6.2-i586-4vl70.txz to use ntrack-013 instead...pls confirm...

qca?
which path do u mean?
can u be more specific?
« Last Edit: April 28, 2011, 12:49:52 am by hata_ph »

amigib

  • Member
  • *
  • Posts: 3
Re: KDE-4.6.2 and it dependencies
« Reply #23 on: April 28, 2011, 03:20:36 am »
Now is

/usr/pkg-config/qca2.pc

and should be

/usr/lib/pkg-config/qca2.pc

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: KDE-4.6.2 and it dependencies
« Reply #24 on: April 28, 2011, 04:39:40 pm »
Now is

/usr/pkg-config/qca2.pc

and should be

/usr/lib/pkg-config/qca2.pc

You are right. I have rebuild the 3rd version and have upload it to my contrib folder. :)

stretchedthin: pls help to move to the testing repo and remove qca-2.0.3-i586-2vl70...

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: KDE-4.6.2 and it dependencies
« Reply #25 on: April 28, 2011, 06:06:00 pm »
Hi hata.ph
Your rebuilt packages have been moved to repo and the old ones removed.
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: KDE-4.6.2 and it dependencies
« Reply #26 on: April 28, 2011, 06:17:22 pm »
Hi hata.ph
Your rebuilt packages have been moved to repo and the old ones removed.


thanks...

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: KDE-4.6.2 and it dependencies
« Reply #27 on: April 28, 2011, 06:18:30 pm »
configure printer setting from system setting encounter below error...any idea?
i try upgrade pycups and system-config-printer but no avail...

Quote
systemsettings(5528)/python (plugin): Error while running factory function for Python plugin:  "system-config-printer-kde/system-config-printer-kde.py"
Traceback (most recent call last):
  File "<string>", line 18, in kpythonpluginfactory_bridge
  File "/usr/share/apps/system-config-printer-kde/system-config-printer-kde.py", line 4011, in CreatePlugin
    kcm = u.makeui(component_data, widget_parent)
  File "/usr/share/apps/system-config-printer-kde/system-config-printer-kde.py", line 128, in makeui
    self.ui = PyKcm(component_data, parent, self)
  File "/usr/share/apps/system-config-printer-kde/system-config-printer-kde.py", line 104, in __init__
    uic.loadUi(unicode(APPDIR + "/" + "system-config-printer.ui"), self)
  File "/usr/lib/python2.7/site-packages/PyQt4/uic/__init__.py", line 185, in loadUi
    return DynamicUILoader().loadUi(uifile, baseinstance)
  File "/usr/lib/python2.7/site-packages/PyQt4/uic/Loader/loader.py", line 35, in loadUi
    return self.parse(filename, basedir)
  File "/usr/lib/python2.7/site-packages/PyQt4/uic/uiparser.py", line 839, in parse
    actor(elem)
  File "/usr/lib/python2.7/site-packages/PyQt4/uic/uiparser.py", line 686, in createUserInterface
    self.traverseWidgetTree(elem)
  File "/usr/lib/python2.7/site-packages/PyQt4/uic/uiparser.py", line 664, in traverseWidgetTree
    handler(self, child)
  File "/usr/lib/python2.7/site-packages/PyQt4/uic/uiparser.py", line 406, in createLayout
    self.traverseWidgetTree(elem)
  File "/usr/lib/python2.7/site-packages/PyQt4/uic/uiparser.py", line 664, in traverseWidgetTree
    handler(self, child)
  File "/usr/lib/python2.7/site-packages/PyQt4/uic/uiparser.py", line 443, in handleItem
    self.traverseWidgetTree(elem)
  File "/usr/lib/python2.7/site-packages/PyQt4/uic/uiparser.py", line 664, in traverseWidgetTree
    handler(self, child)
  File "/usr/lib/python2.7/site-packages/PyQt4/uic/uiparser.py", line 161, in createWidget
    QtGui.QScrollArea, QtGui.StackedWidget,
AttributeError: 'module' object has no attribute 'StackedWidget'
systemsettings(5528)/python (plugin): Failed to import module
systemsettings(5528)/kcontrol KCModuleLoader::loadModule: This module has no valid entry symbol at all. The reason could be that it's still using K_EXPORT_COMPONENT_FACTORY with a custom X-KDE-FactoryName which is not supported anymore
systemsettings(5528)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: KDE-4.6.2 and it dependencies
« Reply #28 on: April 28, 2011, 06:41:57 pm »
It looks like you need to upgerade pyqt to 4.8.3

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: KDE-4.6.2 and it dependencies
« Reply #29 on: April 28, 2011, 06:45:39 pm »
It looks like you need to upgerade pyqt to 4.8.3

thanks for you help...edit below file solve the issue

Quote
"/usr/lib/python2.7/site-packages/PyQt4/uic/uiparser.py", move to line 161 and replace "QtGui.StackedWidget" with "QtGui.QStackedWidget".