VectorLinux
July 22, 2014, 03:23:09 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: APM + mounting pendrives or digital cameras  (Read 1491 times)
scififry
Member
*
Posts: 66


« on: April 28, 2011, 03:32:32 am »

Hello!
Could somebody please help me with the following things?

1. How do I enable APM? When shutting down, Linux says
Quote
apm disabled on user request
But I didn't disable anything! I want to use APM because the PC is on the whole day, but I'm not sitting in front of it the whole day so I can save my CRT monitor by easily switching it off instead of a screensaver.

2. How can I mount digital cameras or USB sticks? If I connect a digital cam or USB stick VL-HOT says while booting
Quote
New USB full speed device found
, but it comes neither into the /mnt directory nor into fstab, and
Code:
mount /mnt/sda1
or something similar do not work. Undecided

Thanks for help! Smiley

EDIT + update: No need for help with APM anymore, found it out myself. After all, i didn't enable it! Because my old HD (13 years) crashed, i had to make a new installation (lost no /home data, it was just for /root and swap), and found the ACPI option to enable. I thought it was only for ACPI and didn't enable it because my computer has the older APM, but it turned out that it is for power management in general, so for both APM+ACPI. Should be working now.
« Last Edit: May 02, 2011, 03:40:25 am by scififry » Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3177



« Reply #1 on: April 28, 2011, 04:26:58 am »

You are not telling mount what to mount... that's why it's looking in fstab.
Code:
mount /dev/sda1 /mnt/sda1
Logged

scififry
Member
*
Posts: 66


« Reply #2 on: April 28, 2011, 04:38:08 am »

Ahh, thank you for your help!
I didn't know that because you don't have to specify anything on Debian-based distros like Damn Small Linux.
Logged
scififry
Member
*
Posts: 66


« Reply #3 on: April 28, 2011, 04:53:43 am »

OK, tried that. The camera's access lamp blinks, but then the terminal says:
Quote
mount: mount point /mnt/sda does not exist
How do i create a mount point? I think it has to be specified as a mount point, or is it just a directory placed in the /mnt directory?
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3177



« Reply #4 on: April 28, 2011, 04:55:51 am »

Code:
mkdir /mnt/sda1
Logged

scififry
Member
*
Posts: 66


« Reply #5 on: April 28, 2011, 05:05:10 am »

 Cheesy Yay, it works!
Logged
Andy Price
Packager
Vectorite
****
Posts: 237


« Reply #6 on: April 28, 2011, 05:18:49 am »

I'm glad you've got it working, but I'm a bit confused. USB drives should automatically mount when you insert them without any intervention from the user. If you are using VLHot then a few seconds after you insert the drive a pair of icons should appear on the desktop, one to show the contents and the other to dismount the drive. Are you saying this doesn't happen? Or are you trying to mount them at boot time?
Andy
Logged
scififry
Member
*
Posts: 66


« Reply #7 on: April 28, 2011, 05:50:47 am »

It doesn't happen because I've disabled this feature, that means I'm using VL-HOT, and it only scans for new devices at boot time. The installer asked me if I want to use VL-HOT or another (can't remember its name), and explained that VL-HOT only scans for new devices at boot time, and the other one currently while VL is running. Because it also recommended using that one which scans for new hardware currently not on slower systems I chose VL-HOT.

BTW, I'm using VL 6.0 Light, maybe it's different in other versions?
Logged
Andy Price
Packager
Vectorite
****
Posts: 237


« Reply #8 on: April 28, 2011, 06:55:09 am »

Well, I'm using Standard, but I don't think any it's different on Light. Both VLHot and the alternative, HAL, should detect USB drives when they are inserted. The difference between the two, if my understanding is correct, is that HAL looks for new hardware continuously and therefore takes up resources, whereas VLHot uses a different mechanism which is much less demanding and therefore more suitable for old equipment. If you selected VLHot when you installed and haven't done anything else to disable it then it should mount your drives on insertion if it's working correctly. Only being able to mount flash drives at boot time would be very inconvenient.
Logged
scififry
Member
*
Posts: 66


« Reply #9 on: April 28, 2011, 07:53:54 am »

hmmh Undecided
It doesn't seem to do anything automatically and there don't come any new icons to my desktop. Even when I'm typing when I connected the device after boot
Code:
root:# mount /dev/sda1 /mnt/sda
it says
Quote
mount: special device /dev/sda1 does not exist
but when the device is connected before boot, it works fine. And when I disconnect the device after unmounting
Code:
umount /mnt/sda
and want to "remount" it later, it also doesn't work.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4018



« Reply #10 on: April 28, 2011, 11:16:12 am »

You can get a good picture of what is happening by monitoring the system messages. Try this:
- In a terminal, as root, enter command "tail -f /var/log/messages"
- watch the terminal as you plug in the USB device
- you should see what device designation it receives and where it gets mounted, or any error messages.
Logged
scififry
Member
*
Posts: 66


« Reply #11 on: April 28, 2011, 11:50:43 am »

Thanks for your advice, nightflier!
Hmh tried that. It monitors activity on my LAN card, but nothing happens when i connect the digital cam. :-/
Is the problem maybe the device or my USB controller? They're both old (1998).
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4018



« Reply #12 on: April 28, 2011, 01:22:31 pm »

So if I understand this correctly; if the USB storage device is connected when you start the machine, then you can mount it. Otherwise not.

I guess it is possible that the controller does not signal the OS upon insertion or removal. You can manually probe for storage devices with command "fdisk -l" (again, as root, in a terminal, and that's a small L).
Logged
scififry
Member
*
Posts: 66


« Reply #13 on: April 28, 2011, 02:05:36 pm »

Yes, right.
Hmh, this seems to be a very special problem. fdisk -l lists all my hard disks, but not the cam. Really weird.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4018



« Reply #14 on: April 29, 2011, 03:56:50 am »

Some cameras do not register as USB storage. For those you need something like gtkam, gphoto2 or digikam.

Can you see a thumb drive if you plug it in?
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!