VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: No modules loading on 2.6.39  (Read 5239 times)

budulay

  • Packager
  • Vectorian
  • ****
  • Posts: 568
  • NewComer
No modules loading on 2.6.39
« on: May 26, 2011, 08:39:22 pm »

I tried building 2.6.39 on VL7RC1, which builds and installs nicely, but when I boot into it, no modules load(I get no output from lsmod). Any idea on why this could be happening?

The modules are installed(I can see a whole bunch of files in /lib/modules/2.6.39).

Here's how I build it:

make oldsilentcolfig - used the RC1 config as the base
make -j4
make modules - tried with or without this, but still got the same result

and installed it:

make modules_install
make install
<modified lilo.conf>
lilo -v

Thanks :)
Logged
VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3280
Re: No modules loading on 2.6.39
« Reply #1 on: May 27, 2011, 05:35:10 am »

did you do `depmod -a` ?

budulay

  • Packager
  • Vectorian
  • ****
  • Posts: 568
  • NewComer
Re: No modules loading on 2.6.39
« Reply #2 on: May 27, 2011, 09:58:03 pm »

Thanks for jumping in on this one ;)

I think "make modules_install" calls depmod after installing the modules, but just to make sure I did "depmod -a 2.6.39" but stll get no modules.
I also tried "depmod -a -r 2.6.39" with the same result.
I don't know if it matters or not, but I've build the kernel under my user and not the root account(I was following the book "Linux Kernel in a Nutshell").
Logged
VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!