VectorLinux
December 22, 2014, 07:20:07 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Trying to get Google Chrome  (Read 1832 times)
pottzie
Member
*
Posts: 94


« on: May 15, 2011, 11:32:00 am »

 Just did a fresh install of Vector 6.0 lite, and I'm trying to get Google Chrome working following opensourcebistro's instructions. Problem came when I tried to get mozilla-nss 3.12.3 from slackfind.net. The only version listed was 3.12.4, so I went with the 32-bit version. After finishing what the guide suggested, when I type "google-chrome" in the terminal, it shows:
 vl:$ google-chrome
/usr/bin/google-chrome: error while loading shared libraries: libpam.so.0: cannot open shared object file: No such file or directory

 Tried searching, but it's broken, as reported in other threads.
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: May 15, 2011, 04:14:36 pm »

Have not been on any of the 6.0's in a while, but I think mozilla-nss is now part of the repositories.  You may want to unintall the slackfind one and use the one in repo.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
pottzie
Member
*
Posts: 94


« Reply #2 on: May 15, 2011, 06:03:55 pm »

 Used Midnight Commander to remove the mozilla-nss, and checked the repositories. There was no "mozilla" nss, but there was one that was just "nss" so I installed it. Now I have:
  vl:$ google-chrome
/usr/bin/google-chrome: error while loading shared libraries: libnss3.so.1d: cannot open shared object file: No such file or directory
 Which is a little different, but with the same result.

 I re-ran the  chmod 777 /dev/shm and cp /opt/google/chrome/google-chrome.desktop /usr/share/applications/ commands.

   BTW, is there a VL 7.0 lite?  The reason I loaded Vector is because it has Chestnut Dialer, and dial-up is all I have when I take the computer to work.
Logged
haywire
Vectorian
****
Posts: 507


« Reply #3 on: May 29, 2011, 02:26:06 am »

I too tried to get chrome installed but wasn't able to get it going myself.

Someone really should build a working install from gslapt for chrome. Its worlds faster than firefox, and perfect for vector lite...

Steven
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4039



« Reply #4 on: May 29, 2011, 03:58:03 am »

I remember having to make several symlinks to get it working. As root, in a terminal:
Code:
cd /usr/lib
ln -s libnss3.so libnss3.so.1d
ln -s libnssutil3.so libnssutil3.so.1d
ln -s libsmime3.so libsmime3.so.1d
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!