VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: VL freezing on boot, reason: Wireless rtl8185  (Read 2850 times)

tian

  • Member
  • *
  • Posts: 4
VL freezing on boot, reason: Wireless rtl8185
« on: June 05, 2011, 05:53:13 pm »

Hi people:

I just installed VectorLinux, and seems quite good, nice and fast. However, an old issue popped out: Mi wireless connection.

In short, VL freezes on boot (specifically, while initializating XFCE). The reason seems to be the Wireless card. When I get it out, the system boots fine. BTW, this also happened with others distros (slitaz, and Mint too)

I tried almost anything to fix the problem. I used ndiswrapper, installed the Realtek drivers for linux, blacklisted r818x and r8187... Nothing worked...
Any ideas?

P.D.: soory about my english, argentine here =P
Logged

tian

  • Member
  • *
  • Posts: 4
Re: VL freezing on boot, reason: Wireless rtl8185
« Reply #1 on: June 05, 2011, 10:25:07 pm »

ok, i've followed the instructions in here: http://forum.vectorlinux.com/index.php?topic=1282.0
I managed to make some advance using ndiswrapper.

I have wicd disabled on boot, and now I can boot the system with the wireless card plugged in. I checked "ndiswrapped -l" and says the driver is installed and the device is present, but when i try tu run wicd, configure the card, etc... the system freezes and I'm forced to reboot...

what now?
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: VL freezing on boot, reason: Wireless rtl8185
« Reply #2 on: June 06, 2011, 07:32:26 am »

This may sound like a cop out, but what about just getting another wireless card?
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

tian

  • Member
  • *
  • Posts: 4
Re: VL freezing on boot, reason: Wireless rtl8185
« Reply #3 on: June 06, 2011, 09:12:32 am »

Well, I actually was thinking about buying another one, but i just wanted to give it a try... whatever, I've got some money saved... do you guys know about any decent (not too expensive) wireless card?? needless to say, NO realtek chipset! =P
Logged

tian

  • Member
  • *
  • Posts: 4
Re: VL freezing on boot, reason: Wireless rtl8185
« Reply #4 on: June 07, 2011, 08:54:57 am »

So, Im still dealing with this...

I managed to make the wireless card work, but the connection doesn't work...
I installed the Linux drivers from Realtek, blacklisted rtl8180, and everything looked good. When I connect to my network, wicd takes a long time trying to assign IP (using DHCP), after a while, it says that "Im connected" but I can't acces the web...
I tried tu ping some sites, but it immediately says "Network Unreachable"..

any ideas?

Tian
Logged