VectorLinux
December 20, 2014, 06:13:38 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: HOWTO on XFCE  (Read 6737 times)
Freeman
Tester
Vectorite
****
Posts: 323


Choice to the user!


« on: January 02, 2007, 12:14:10 pm »

Change your desktop icons

You need to create a file called  ~/.gtkrc-2.0:

style "xfdesktop-icon-view" {
    XfdesktopIconView::label-alpha = 75

    base[NORMAL] = "#00ff00"
    base[SELECTED] = "#5050ff"
    base[ACTIVE] = "#0000ff"

    fg[NORMAL] = "#000000"
    fg[SELECTED] = "#ff0000"
    fg[ACTIVE] = "#ff0000"
}
widget_class "*XfdesktopIconView*" style "xfdesktop-icon-view"

The first entry sets the opacity of the rounded text background.  The allowed
values are from 0 (totally transparent) to 255 (totally opaque).

The second three entries set the color of the rounded text background.
* NORMAL sets the color for the regular, unselected state.
* SELECTED sets the color for when the icon is selected, and the desktop has
  keyboard/mouse focus.
* ACTIVE sets the color for when the icon is selected, but the desktop does
  not have keyboard/mouse focus.

The final three entries set the color of the label text.  See above for the
differences between NORMAL, SELECTED, and ACTIVE.

Hide icons in the menus

You may also want to show or hide the icons in the desktop menu (right-click)
and the window menu (middle-click).  This is controlled by the global gtk
"gtk-menu-images" style property, which can be set by adding something like
the following to your ~/.gtkrc-2.0 file:

style "menu-images" {
    gtk-menu-images = false
}
widget_class "*" style "menu-images"

Unfortunately, this will act on all gtk menus, not just on the desktop or
window menu.  There is currently no way to set this property just for these
two menus.

Hide Home, Filesystem & Trash icons

The file icon view by default shows 'special' icons for the root of your
filesystem, your home directory, and the trash.  Removable volumes (such as
USB flash drives) are also shown when they are plugged in.  If you'd like to
configure which of these are shown, edit (or create) the file
~/.config/xfce4/desktop/xfdesktoprc to look something like this:

[file-icons]
show-filesystem=true
show-home=true
show-trash=true
show-removable=true

The defaults are all 'true', but you can set ones you want hidden to 'false'.
If an entry is omitted, it defaults to 'true'.  You will need to restart
xfdesktop to make the settings take effect.

Changing Keystrokes

By default, the windows key is considered Super_L, a modifier key. Therefore you'd have to bind a command to windows+[some_key], which is not what we want. So what you want to do is re-map your windows key so that it's not a modifier. The easiest way to do this is to use xmodmap like so:

Code:
xmodmap -e "keycode 115 = Menu" &

"Menu" above specifies that when you press the windows key, it will pop-up the app's menu. We will later overwrite this to pop-up an Xfce menu. The 115 above is the keycode for the windows key. It should work for most people, but you can verify what it is for you with xev.

Assigning a different menu to the windows key:

- Fire up settings from the panel
- Click on Window manager and select the tab keyboard
- Create a new keyboard map or select your current one. Note that you cannot modify the default one
- Double click on one of the commands to edit it. Replace the existing text (none for not assigned) to (for instance) xfdesktop -menu and then when prompted for a shortcut press the Windows key.

If this all works out for you, you may wish to put the xmodmap command in your .xinitrc or .xsession file so that it will execute on startup.

Some XFCE Goodies/Plugins:
http://slackpacks.rlworkman.net/11.0/xfce4-goodies/
« Last Edit: January 05, 2007, 10:51:18 am by Freeman » Logged

It's better to die 10 times, than never to have loved at all.
Freeman
Tester
Vectorite
****
Posts: 323


Choice to the user!


« Reply #1 on: January 02, 2007, 12:16:40 pm »

Everything works fine, except the last one, for removing the extra icons on the desktop created by xfce. If someone does succeed, please enlight me.

This tutorial comes straight from the README but has proven me handy allready.
Logged

It's better to die 10 times, than never to have loved at all.
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #2 on: January 03, 2007, 04:46:03 pm »

Everything works fine, except the last one, for removing the extra icons on the desktop created by xfce.
Sorry, but it is not clear to me which icons you are referring to here.
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Freeman
Tester
Vectorite
****
Posts: 323


Choice to the user!


« Reply #3 on: January 04, 2007, 06:31:25 am »

Code:
[file-icons]
show-filesystem=true
show-home=true
show-trash=true
show-removable=true

This part doesn't work for me...
Logged

It's better to die 10 times, than never to have loved at all.
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #4 on: January 04, 2007, 03:55:53 pm »

Ah, ok thanks. So we're still stuck with File System and Home then...  Angry
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Freeman
Tester
Vectorite
****
Posts: 323


Choice to the user!


« Reply #5 on: January 05, 2007, 07:04:38 am »

It's not fun to admit I can't get it to work, but yes, we are still stuck with those damn! icons  Undecided
Logged

It's better to die 10 times, than never to have loved at all.
tab0reqq
Member
*
Posts: 36



« Reply #6 on: January 28, 2007, 12:44:54 pm »

EDIT:

Code:
[file-icons]
show-filesystem=true
show-home=true
show-trash=true
show-removable=true
Works fine on xfce4.4 (not 3.99.rcX)

« Last Edit: January 28, 2007, 12:51:10 pm by tab0reqq » Logged

Software: VL 5.8 Gold | Kernel 2.6.19.2 | X.org 6.9 | Xfce 4.4
tab0reqq
Member
*
Posts: 36



« Reply #7 on: February 01, 2007, 08:01:37 am »

Jeez, i don't understand this xfce4. I wrote that desktop icons-hiding works. yes. it worked but i reinstalled x11 6.9.0 (i had to) and now thi tip doesn't work. I modified all xfdesktop's on root and user without any results.

Any ideas?
Logged

Software: VL 5.8 Gold | Kernel 2.6.19.2 | X.org 6.9 | Xfce 4.4
rworkman
Member
*
Posts: 6


« Reply #8 on: September 19, 2007, 06:44:57 am »


This link is no longer valid --the correct location is http://rlworkman.net/pkgs/
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!