VectorLinux
July 23, 2014, 03:57:58 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: HOWTO: Upgrade to xorg 7.x on VL 5.8 STD  (Read 4126 times)
M0E-lnx
Administrator
Vectorian
*****
Posts: 3178



« on: January 02, 2007, 12:29:23 pm »

UPGRADING XORG ON VECTOR LINUX 5.8

For those of you who would like to enjoy some eye-candy, (ie, beryl, xgl, compiz) You'll need to upgrade your xorg. This howto will tell you how to do that...

Assumptions:
  • You must be skilled enough to figure your way out of a serious mess in case you have to, using the CLI
  • You are ready to reinstall your OS if you need to (back up important data before proceding)
  • You will download your xorg packages to ~/xorg7, so mkdir ~/xorg7 now

With that said, let's begin.

Step 1
Download the necessary packages.
Larhzu has been nice enough to let us use his packages... here is a list of what you need to get a minimal nvironment going
  • x11-base-7.1
  • x11-xserver-7.1
  • x11-fonts-base-7.1
  • x11-fonts-100dpi
  • x11-fonts-75dpi
  • x11-fonts-cyrillic
  • x11-fonts-scale

Here is a link where you can find these http://ftp://tukaani.org/tukaani/tukaani-edge/slackware/x/
Download them to some to a dir on your box ( I created ~/xorg7 for the sake of this process)

Now that you have all the packages, the next step.

Step 2
Drop down to CLI
Code:
# init 2

Step 3
Remove the existing X11 symlink in /usr which points to X11R6
Code:
# rm /usr/X11

Step 4
Install your new xorg packages
Code:
# cd /home/username/xorg7
# installpkg *

Note that the new xorg installs to /usr/ and not /usr/X11R6 like the old one.... hence, the following part of this howto:

Step 5
Modify your xorg configuration.
Code:
# cp /etc/X11/xorg.conf /etc/X11/xorg.conf-6.9
# mcedit /etc/X11/xorg.conf

We are going to modify the paths sectio of the file only.

Make it look like this:

Section "Files"
Quote
    RgbPath         "/usr/lib/X11/rgb"
    ModulePath     "/usr/lib/xorg/modules/"
    FontPath        "/usr/lib/X11/fonts/misc/"
    FontPath        "/usr/lib/X11/fonts/100dpi/"
    FontPath        "/usr/lib/X11/fonts/75dpi/"
    FontPath        "/usr/lib/X11/fonts/misc/"
    FontPath        "/usr/lib/X11/fonts/Type1/"
    FontPath        "/usr/lib/X11/fonts/100dpi/"
    FontPath        "/usr/lib/X11/fonts/75dpi/"
    FontPath        "/usr/lib/X11/fonts/cyrillic/"
Save and exit

Step 6
Create the X11 symlink pointing to /usr
Code:
cd /usr && ln -s /usr X11

Step 7
Reinstall your video drivers if you (may or may not be needed, depending on your hardware (my NVIDIA did need reinstall ))

Hang on to something, we're ready for testing..
[/b]Step 8 [/b]
Code:
# init 4

If you x does not fire up, don't panic just yet.... log in as USER again... and try startxfce4 ... you should see your new xorg now...

KNOWN ISSUES

After this procedure, your xfce session manager may not work as it did in the previous xorg... (ie, when you click on the quit button from the menu, you'll see nothing)

To fix this, check your /var/log/Xorg.0.log and pay close attention also to your ~/.xsession-errors you should find the information needed to fix this in those log files...

ANOTHER THING. I still haven't managed to get init 4 to load the GUI... so I just startxfce4 manually every time...

ONE more thing. xconf does not work after this, because vasm is looking for /usr/X11R6 to configure, but you're running it from /usr... so you'll do the configuration manually.... (if you run nvidia, their installer will do it for you Wink )

At the moment, I have still not been able to restore 3D acceleration after upgrading xorg on an intel video chip.

Other than that, it works like a charm.... Enjoy!....

If you find any solutions to the known issues with this howto, please post them here... other than that, ALL QUESTIONS ARE TO BE POSTED IN THE APPROPRIATE SECTION OF THE FORUM


EDIT
I've re-written this howto and added xorg-7.2 packages at http://m0e.lnx.googlepages.com The new xorg packages feature better hardware support (Intel, Nvidia and ATI should be able to get 3D easily)
Check it out
« Last Edit: February 20, 2007, 01:02:17 pm by M0E-lnx » Logged

shahgols
Vectorite
***
Posts: 206


« Reply #1 on: April 15, 2007, 10:49:01 am »



ANOTHER THING. I still haven't managed to get init 4 to load the GUI... so I just startxfce4 manually every time...


Hi M0E, thanks for this tutorial and I was able to install xorg 7.2 easily.  I have the above problem and wanted to know if you have figured out a way to fix this?  Thanks.
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #2 on: April 15, 2007, 06:59:18 pm »

try changing line 17 of /etc/rc.d/rc.X from
KDM_CMD=/opt/kde/bin/kdm

to
KDM_CMD=`which kdm`

let us know if that fixes it.
Thanks,
Uelsk8s

Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!