VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: changing kbd from english to spanish- SOLVED  (Read 152 times)

macondo

  • Vectorite
  • ***
  • Posts: 109
changing kbd from english to spanish- SOLVED
« on: July 31, 2015, 10:30:28 am »

The default in the installation is English, i use a Spanish one, how can I change it to Spanish, thank you.
« Last Edit: August 09, 2015, 09:07:56 pm by macondo »
Logged
VL 7.1 Light - icewm/jwm/ratpoison
"Sometimes a man finds his destiny on the road he took to avoid"

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2322
Re: changing kbd from english to spanish
« Reply #1 on: July 31, 2015, 11:27:42 am »

Hi macondo,

I use "setxkbmap es" from the terminal.
If you use Xfce, you can also go to the menu, settings, keyboard, and find the layout tab in top right. You can select your keyboard model and layout there.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

macondo

  • Vectorite
  • ***
  • Posts: 109
Re: changing kbd from english to spanish
« Reply #2 on: July 31, 2015, 12:17:48 pm »

Hi Rbistolfi, thanks for the tip, it worked perfectly. After a while i got tired of typing it so i put it in .xinitrc, here's mine, so i don't have to type it anymore:

Code: [Select]
#!/bin/sh

setxkbmap es
firefox &
setxkbmap -option terminate:ctrl_alt_bksp
xsetroot -solid black
unclutter -idle 2 &
numlockx &

exec icewm
Logged
VL 7.1 Light - icewm/jwm/ratpoison
"Sometimes a man finds his destiny on the road he took to avoid"

Nitoactiree

  • Member
  • *
  • Posts: 2
  • user
    • Отзывы о KIA
changing kbd from english to spanish SOLVED
« Reply #3 on: August 15, 2015, 09:40:58 am »

During installation I got a message about being unable to inject zimlets. Is there a fix for this that I should run after I replace the jnilib.

-Rob
Logged