Please support VectorLinux!

Author Topic: 20110713 firefox-5.0 [VL7.0]  (Read 2963 times)

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
20110713 firefox-5.0 [VL7.0]
« on: July 12, 2011, 10:15:44 pm »
vector has built a new Firefox package for VectorLinux 7.0.
   
      
   
Code: [Select]
firefox: Standalone web browser from mozilla.org
firefox:
firefox:
firefox:
firefox:
firefox:
firefox:
firefox: License: MPL
firefox: Authors:
firefox: Website: http://www.mozilla.org/projects/firefox
   
   After testing this package please stop back here and let us know how it works for you.
   
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: 20110713 firefox-5.0 [VL7.0]
« Reply #1 on: July 14, 2011, 06:33:43 pm »
trying to install firefox-5.0 from VL7-RC1 and it say missing glibc >= 2.28.7

Quote
firefox: Depends: glib2 >= 2.28.7

It seem glibc-2.28.6 is the only available package in the repo...

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: 20110713 firefox-5.0 [VL7.0]
« Reply #2 on: July 14, 2011, 09:00:32 pm »
Yes...I know i am using RC1 but if the dependencies is not in the repo...what happen if someone want to reinstall that specific packages?

Sty

  • Packager
  • Vectorite
  • ****
  • Posts: 114
Re: 20110713 firefox-5.0 [VL7.0]
« Reply #3 on: July 18, 2011, 07:23:16 am »
I had an error for pixman dependancy, (sorry lost the exact requirement) and am running VL7 RC2.
* Enterprise *
Running Vector Linux 5.9 Deluxe
|| Intel Core2Duo E6600 | 4 GB DDR2 RAM | ATi Radeon X1900XT ||

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: 20110713 firefox-5.0 [VL7.0]
« Reply #4 on: July 18, 2011, 11:57:31 am »
I had an error for pixman dependancy, (sorry lost the exact requirement) and am running VL7 RC2.

I think the pixman dependency would be resolved by making sure the extra repository is enabled.  If you can get the exact requirement then I could find out for sure.
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: 20110713 firefox-5.0 [VL7.0]
« Reply #5 on: August 11, 2011, 10:24:32 am »
Yes...I know i am using RC1 but if the dependencies is not in the repo...what happen if someone want to reinstall that specific packages?

Me too... ;D

BTW, forcing install when that is the only dependency issue is no problem (probably a minor bugfix), however, gslapt only gives warning on the first dependency failure for each package, so once you accept, you won't find out about all the rest... :o

Also, this firefox is failing to run for me with the following libpng error. I even upgraded to the slack-13.37 libpng-1.4.8 with no success:
Code: [Select]
joe1962:$ firefox 
/usr/lib/firefox-5.0/firefox-bin: relocation error: /usr/lib/firefox-5.0/libxul.so: symbol png_get_first_frame_is_hidden, version PNG14_0 not defined in file libpng14.so.14 with link time reference
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10