VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: No sound in browsers [SOLVED]  (Read 3102 times)

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
No sound in browsers [SOLVED]
« on: August 01, 2011, 02:23:58 pm »

I switched my NVidia GeForce GT220 video card from the Sempron computer to the Athlon II. I immediately ran into a "no sound" problem in both Win 7 and VL7 Standard RC2, which my friend google showed me how to fix. I had to go into BIOS and change Onboard Sound from "Auto" to "Enable." That immediately fixed the sound problem in Windows and VL7.

The problem was that the video card includes the possibility of connecting with HDMI and unless the computer is forced to use the onboard sound (ATI IXP), it "automatically" selects the HDMI sound through the video card. I don't have any HDMI connections, so if it's using the video card's HDMI, I get no sound.

VL 7 wants to use HDMI. I selected ATI IXP in Alsamixer and in XFce's mixer, but still no sound in browsers. I do get sound if I play an audio file with VLC or Gnome MPlayer but not necessarily other media players (Exaile doesn't work, for example).

What I want to know is how to blacklist or otherwise completely disable the NVidia HDMI audio option so I can make ATI IXP audio the only option. Thanks in advance.
--GrannyGeek
« Last Edit: August 02, 2011, 09:46:04 am by GrannyGeek »
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: No sound in browsers
« Reply #1 on: August 01, 2011, 04:31:22 pm »

Went back and looked at some of the video I've made over the years.  Here are two that may suite your purpose.
http://www.opensourcebistro.com/Tutorial/VL60/01.Installation/defaultsound/defaultsound.htm
http://www.youtube.com/watch?v=TsgOFHCJAUE
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: No sound in browsers
« Reply #2 on: August 02, 2011, 09:44:13 am »

Thanks! For some reason I'm not seeing all new messages when I click on "Show unread posts since last visit." I guess I'll have to click on "Show new replies to your posts," too.

Before I read your message I managed to fix it (I think). It occurred to me that I'd seen messages on the forum about people's webcams interfering with their sound, so I did a search and found a reference to http://forum.vectorlinux.com/index.php?topic=4888.msg32619#msg32619 . I tried the fix and when I rebooted and started Opera, lo and behold it played the sound! I figured the situations were basically the same.

Now I'll check your suggested links and see if you described the same fix.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller