VectorLinux
October 31, 2014, 09:46:59 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: External usb hard drive will not mount <solved>  (Read 4343 times)
InTheWoods
Vectorite
***
Posts: 302


« on: August 10, 2011, 01:56:58 pm »

I have two identical usb connected external hard drives. HAL automounts the one and not the other. lsusb shows both drives but I cannot mount the one even manually with mount /dev/sda.

How can I access the second drive. Both drives are accessible on another computer running windows.
« Last Edit: August 10, 2011, 05:53:39 pm by InTheWoods » Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #1 on: August 10, 2011, 02:09:51 pm »

I have seen this before if the drive is NTFS and filesystem is not clean. In that case you may have to force a mount.

Before you plug in the troublesome drive, in a root terminal give command:
Code:
tail -f /var/log/messages
Now plug in the drive and monitor the terminal for error messages.

Logged
InTheWoods
Vectorite
***
Posts: 302


« Reply #2 on: August 10, 2011, 02:47:33 pm »

So it does appear to be NTFS.

Here are the results of
Code:
tail -f /var/log/messages

Code:
Aug 10 18:55:00 vector kernel: usb 1-4: new high speed USB device using ehci_hcd and address 7
Aug 10 18:55:00 vector kernel: usb 1-4: configuration #1 chosen from 1 choice
Aug 10 18:55:00 vector kernel: scsi7 : SCSI emulation for USB Mass Storage devices
Aug 10 18:55:04 vector gnome-keyring-daemon[4014]: Scheduling hal init retry
Aug 10 18:55:05 vector kernel: scsi 7:0:0:0: Direct-Access     Seagate  FreeAgent        0138 PQ: 0 ANSI: 4
Aug 10 18:55:05 vector kernel: sd 7:0:0:0: [sda] 1953525166 512-byte hardware sectors (1000205 MB)
Aug 10 18:55:05 vector kernel: sd 7:0:0:0: [sda] Write Protect is off
Aug 10 18:55:05 vector kernel: sd 7:0:0:0: [sda] 1953525166 512-byte hardware sectors (1000205 MB)
Aug 10 18:55:05 vector kernel: sd 7:0:0:0: [sda] Write Protect is off
Aug 10 18:55:05 vector kernel:  sda: sda1
Aug 10 18:55:05 vector kernel: sd 7:0:0:0: [sda] Attached SCSI disk
Aug 10 18:55:05 vector kernel: sd 7:0:0:0: Attached scsi generic sg0 type 0
Aug 10 18:55:05 vector vl-hot_mount: Starting vl-hot_mount...
Aug 10 18:55:05 vector vl-hot_mount: Mounting device sda
Aug 10 18:55:05 vector vl-hot_mount: ALERT: /dev/vl-hot/sda not mountable (MBR)...
Aug 10 18:55:05 vector vl-hot_mount: Finishing vl-hot_mount...
Aug 10 18:55:05 vector vl-hot_mount: Starting vl-hot_mount...
Aug 10 18:55:05 vector vl-hot_mount: Mounting device sda1
Aug 10 18:55:05 vector vl-hot_mount: /dev/vl-hot/sda1 filesystem is NTFS
Aug 10 18:55:05 vector vl-hot_mount: Device serial number: 2GET60HD
Aug 10 18:55:05 vector vl-hot_mount: VOLUME LABEL: FreeAgent_Drive
Aug 10 18:55:05 vector vl-hot_mount: Using device volume label as mountpoint: FreeAgent_Drive
Aug 10 18:55:05 vector vl-hot_mount: Checking if FreeAgent_Drive already used...
Aug 10 18:55:05 vector vl-hot_mount: Mountpoint FreeAgent_Drive is available...
Aug 10 18:55:05 vector vl-hot_mount: Mountpoint /mnt/vl-hot/FreeAgent_Drive exists...
Aug 10 18:55:05 vector vl-hot_mount: Mounting NTFS-3G filesystem /dev/vl-hot/sda1 on /mnt/vl-hot/FreeAgent_Drive
Aug 10 18:55:05 vector vl-hot_mount: Command: ntfs-3g /dev/vl-hot/sda1 /mnt/vl-hot/FreeAgent_Drive -o user,noatime,uid=root,gid=users,fmask=0111,dmask=0000,nls=iso8859-1,rw
Aug 10 18:55:05 vector vl-hot_mount: ERROR: mounting of /dev/vl-hot/sda1 on /mnt/vl-hot/FreeAgent_Drive failed...
Aug 10 18:55:05 vector vl-hot_mount: Finishing vl-hot_mount...
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #3 on: August 10, 2011, 04:46:11 pm »

You're using vl-hot, not HAL. See what happens if you manually try:
Code:
ntfs-3g /dev/sda1 /mnt/hd
Logged
InTheWoods
Vectorite
***
Posts: 302


« Reply #4 on: August 10, 2011, 05:53:03 pm »

Quote
You're using vl-hot, not HAL

Why yes I am

Code:
ntfs-3g /dev/sda1 /mnt/hd
did not work but pointed to this
Code:
mount -t ntfs-3g -o force /dev/sda1 /mnt/hd
which did work.

I had error messages that complained of unclean mount and dismount. Probably from my earlier attempts and your suggestion will probably work in the future.

Is it possible to make vl-hot mount this drive like it's sister drive or is this a forever consequence of NTFS?
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #5 on: August 10, 2011, 05:57:21 pm »

Try running chkdsk on the drive from windows. Once the file system is checked and marked clean, it should mount without the force option.
Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #6 on: August 11, 2011, 04:34:08 am »

Is it possible to make vl-hot mount this drive like it's sister drive or is this a forever consequence of NTFS?

NTFS-3g will, by default, avoid mounting partitions that were not cleanly unmounted in Windows, something all too common, I find, as Windows will often refuse to unmount something even with one of those force unmount utilities. Once it is checked and properly unmounted in Windows, or once it is force-mounted with NTFS-3g, a partition will continue to be auto mounted with no problems (at least until the next time Windows gets its hands on it, LOL).

Now vl-hot can handle this for you if you don't want to go cli when it happens, or if it happens so often you get fed up with the whole thing. Just go to the "FAT/NTFS" tab in vl-hot-config and check the "Forced" option in "NTFS3G options". You can also set this directly by opening /etc/udev/vl-hot.conf in a text editor and changing "NTFS3Gforce=0" to "NTFS3Gforce=1".
« Last Edit: August 11, 2011, 04:35:40 am by Joe1962 » Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
InTheWoods
Vectorite
***
Posts: 302


« Reply #7 on: August 12, 2011, 12:41:59 pm »


Quote
....once it is force-mounted with NTFS-3g, a partition will continue to be auto mounted with no problems

It mounts just fine now. Thanks.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!