VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: 1 [2]

Author Topic: VL64-7.0-STD BETA 1 BUG REPORTS  (Read 4660 times)

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4103
Re: VL64-7.0-STD BETA 1 BUG REPORTS
« Reply #15 on: October 19, 2011, 11:25:16 am »

Here's the whole pkgtools file, it only shows post-install activity.
Code: [Select]
Installed on Wed Oct 19 17:37:53 Local time zone must be set--see zic manual page 2011
2011-10-19 13:55:15 Recreated GNU info directory file: /usr/info/dir.gz
2011-10-19 13:55:15 Installed new: xfce-4.8-x86_64-7vl70.txz
2011-10-19 13:55:15 Installed new: xfce4-cpufreq-plugin-1.0.0-x86_64-1vl70.txz
2011-10-19 13:55:16 Removed: pixman-0.20.2-x86_64-1vl70-upgraded-2011-10-19,13:55:15
2011-10-19 13:55:16 Upgraded: pixman-0.20.2-x86_64-1vl70 to pixman-0.21.6-x86_64-1vl70.txz
2011-10-19 13:55:16 Installed new: xfce4-cpugraph-plugin-1.0.1-x86_64-2vl70.txz
2011-10-19 13:55:16 Installed new: xfce4-datetime-plugin-0.6.1-x86_64-1vl70.txz
2011-10-19 13:55:16 Installed new: xfce4-dict-plugin-0.3.0-x86_64-1vl70.txz
2011-10-19 13:55:16 Installed new: xfce4-diskperf-plugin-2.3.0-x86_64-1vl70.txz
2011-10-19 13:55:16 Installed new: xfce4-eyes-plugin-4.4.1-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-fsguard-plugin-1.0.0-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-genmon-plugin-3.3.0-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-mixer-4.6.1-x86_64-2vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-modemlights-plugin-0.1.3.99-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-mount-plugin-0.5.5-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: libmpd-0.18.0-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-mpc-plugin-0.3.6-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-netload-plugin-1.0.0-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-notes-plugin-1.7.7-x86_64-1vl70.txz
2011-10-19 13:55:18 Installed new: xfce4-power-manager-1.0.10-x86_64-1vl70.txz
2011-10-19 13:55:18 Installed new: xfce4-screenshooter-plugin-1.4.0-x86_64-1vl70.txz
2011-10-19 13:55:18 Installed new: xfce4-smartbookmark-plugin-0.4.2-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-smartpm-plugin-0.4.0-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-systemload-plugin-1.0.0-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-time-out-plugin-1.0.0-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-timer-plugin-0.6-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-verve-plugin-1.0.0-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-wavelan-plugin-0.5.6-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-weather-plugin-0.7.4-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-xmms-plugin-0.5.3-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfswitch-plugin-0.0.1-x86_64-1vl70.txz
« Last Edit: October 19, 2011, 03:11:36 pm by nightflier »
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4103
Re: VL64-7.0-STD BETA 1 BUG REPORTS
« Reply #16 on: October 19, 2011, 11:53:18 am »

Downloaded proprietary nvidia driver. The installer disabled nouveau, built modules and installed perfectly. Judging by glxgears, framerate increased significally.

Tried to build etracer: http://slackbuilds.org/repository/13.37/games/extremetuxracer/
Error from running slacbuild:
Code: [Select]
ppgltk/images/png_reader.cpp:80:49: error: 'int_p_NULL' was not declared in this scope
ppgltk/images/png_reader.cpp:117:47: error: 'png_infopp_NULL' was not declared in this scope
make[2]: *** [png_reader.o] Error 1
make[2]: Leaving directory `/tmp/SBo/extremetuxracer-0.4/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/extremetuxracer-0.4'
make: *** [all] Error 2
When trying to run ./configure on the extracted archive:
Code: [Select]
checking for location of tclConfig.sh... configure: error: tclConfig.sh not found - use the --with-tcl option
Logged

pierce.jason

  • Packager
  • Vectorite
  • ****
  • Posts: 250
Re: VL64-7.0-STD BETA 1 BUG REPORTS
« Reply #17 on: October 19, 2011, 02:43:45 pm »

Missing symlink between /usr/bin/python and /usr/bin/python2 .

This is fixed in python2-2.7.2 package in the repo.

Seems 2.7.2 introduces some other problems.
Code: [Select]
vl64:$ pysol.py
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Traceback (most recent call last):
  File "/usr/lib/python2.7/site.py", line 563, in <module>
    main()
  File "/usr/lib/python2.7/site.py", line 545, in main
    known_paths = addusersitepackages(known_paths)
  File "/usr/lib/python2.7/site.py", line 278, in addusersitepackages
    user_site = getusersitepackages()
  File "/usr/lib/python2.7/site.py", line 253, in getusersitepackages
    user_base = getuserbase() # this will also set USER_BASE
  File "/usr/lib/python2.7/site.py", line 243, in getuserbase
    USER_BASE = get_config_var('userbase')
  File "/usr/lib/python2.7/sysconfig.py", line 520, in get_config_var
    return get_config_vars().get(name)
  File "/usr/lib/python2.7/sysconfig.py", line 419, in get_config_vars
    _init_posix(_CONFIG_VARS)
  File "/usr/lib/python2.7/sysconfig.py", line 287, in _init_posix
    raise IOError(msg)
IOError: invalid Python installation: unable to open /usr/lib/python2.7/config/Makefile (No such file or directory)
 
« Last Edit: October 19, 2011, 03:03:49 pm by pierce.jason »
Logged
pierce.jason
Email: $(echo -e "moc\x2eliamg\x40nosaj.ecreip" | rev)

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: VL64-7.0-STD BETA 1 BUG REPORTS
« Reply #18 on: October 19, 2011, 03:14:11 pm »

Downloaded proprietary nvidia driver. The installer disabled nouveau, built modules and installed perfectly. Judging by glxgears, framerate increased significally.

Tried to build etracer: http://slackbuilds.org/repository/13.37/games/extremetuxracer/
Error from running slacbuild:
Code: [Select]
ppgltk/images/png_reader.cpp:80:49: error: 'int_p_NULL' was not declared in this scope
ppgltk/images/png_reader.cpp:117:47: error: 'png_infopp_NULL' was not declared in this scope
make[2]: *** [png_reader.o] Error 1
make[2]: Leaving directory `/tmp/SBo/extremetuxracer-0.4/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/extremetuxracer-0.4'
make: *** [all] Error 2
When trying to run ./configure on the extracted archive:
Code: [Select]
checking for location of tclConfig.sh... configure: error: tclConfig.sh not found - use the --with-tcl option

there is a png patch here:  http://shining.toofishes.net/etracer/0001-ppgltk-fix-build-with-png-1.4.patch.txt
the others in the dir look useful
you need to use the --libdir=/usr/lib64 with configure so it knows where to look for and place libs
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4103
Re: VL64-7.0-STD BETA 1 BUG REPORTS
« Reply #19 on: October 20, 2011, 07:10:56 am »

there is a png patch here:  http://shining.toofishes.net/etracer/0001-ppgltk-fix-build-with-png-1.4.patch.txt
the others in the dir look useful
you need to use the --libdir=/usr/lib64 with configure so it knows where to look for and place libs

Thanks! After applying the patch it would build. Now Tux "flies" at 130-260 FPS, using 1280x1024 fullscreen.
Logged

eco2geek

  • Member
  • *
  • Posts: 11
Re: VL64-7.0-STD BETA 1 BUG REPORTS
« Reply #20 on: October 20, 2011, 08:30:58 pm »

I installed VLocity onto one of my computer's partitions.

- When using the "Select how Vlocity Linux should use /dev/sdXX" window, selecting "Mountpoint > Other" threw me out of the installer and into JWM (with a gray background). Had to reboot and start over.

- Trying to install LILO to the partition VL was installed on just gave error messages (on 2 attempts). (Which was just as well. I know that Slackware uses LILO, but still.) The installer would only let me install GRUB2 to the MBR of the computer, which is already "controlled" by another version of Linux, so that's not going to happen. It'd be nice to have the option of installing GRUB2 to the partition VL's installed on. I did it manually.

- I use a wireless keyboard that's connected to the computer via USB. During the ncurses part of the setup (setting up X), it didn't recognize the down arrow or up arrow keys, or the Tab key. I had to use vasm later.

- After using vasm to set up X, it wouldn't start. "modesetting" was set as the name of the driver in xorg.conf. Changed it to "nouveau".
Logged

eco2geek

  • Member
  • *
  • Posts: 11
Re: VL64-7.0-STD BETA 1 BUG REPORTS
« Reply #21 on: October 21, 2011, 08:40:32 pm »

After an upgrade, gslapt will no longer run from the menu. (Actually I don't know if it ran from the menu before the upgrade, since I ran it from a terminal.) Problem is that "gksu" is missing from the command to start it.
Logged

MikeCindi

  • Tester
  • Vectorian
  • ****
  • Posts: 1074
Re: VL64-7.0-STD BETA 1 BUG REPORTS
« Reply #22 on: October 24, 2011, 04:54:13 pm »

Initial load went well using text installer. I will do my usual things over the next several days...
Logged
The plans of the diligent lead to profit...Pro. 21:5
 VL64 7.1                                     RLU 486143

scififry

  • Member
  • *
  • Posts: 66
Re: VL64-7.0-STD BETA 1 BUG REPORTS
« Reply #23 on: November 05, 2011, 12:20:27 am »

As I finally got the new power supply for my 64-bit machine I installed VL 64 onto it (Athlon 64 2GHz, 1280MB RAM).

Installation went very smooth, took only about 10 minutes.

When the first time configuration dialogue comes up after booting the freshly installed system for the first time, I cannot navigate between the options using the cursor keys or any other keys that could work for movement. Instead, just things like ^B , ^C and similar (depending on the key) appear in the line of the OK and Cancel buttons.
After just pressing enter without choosing anything I configured everything using vasm; keyboard and video configurations work now.

Cups still won't let me choose the parallel port as printing device (did in VL7 RC2.1 and RC3.4 too). It's an old 24-pin dot matrix printer connected directly to the parallel port and I can provide the required PPD file.

Thunar works fine without any bugs.

Looks very good so far, really good design!

Greetings,
scififry
Logged
Pages: 1 [2]