Please support VectorLinux!

Author Topic: VECTORLINUX 7.0 RC2.1 Bug Reports  (Read 11110 times)

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4073
Re: VECTORLINUX 7.0 RC2.1 Bug Reports
« Reply #45 on: October 07, 2011, 03:34:54 pm »
*scififry commits one of the biggest crimes

Nah, no big deal. We're not fanatics.   :)

scififry

  • Member
  • *
  • Posts: 66
Re: VECTORLINUX 7.0 RC2.1 Bug Reports
« Reply #46 on: October 07, 2011, 05:41:06 pm »
Thanks! :)

Well, I'm. ;) Windos was even too dumb to configure the sound driver, haha.

Buuut.. I should stop talking about that, this thread is about VectorLinux.

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: VECTORLINUX 7.0 RC2.1 Bug Reports
« Reply #47 on: October 08, 2011, 02:06:25 pm »
pierce-jason wrote:

Quote
What version of hplip does slapt-get say you are using?

Gslapt says hplip ver 3.10.2-i586-2vl70.

But I don't think I am using hplip.  I am using cups.  perhaps that is the problem.  But I doubt it.  I am pretty sure that the new slackware kernel just doesn't support usb printer input on some of the not-so-old hp laserjets.

John
VL7.0 xfce4 Samsung RF511

pierce.jason

  • Packager
  • Vectorite
  • ****
  • Posts: 250
Re: VECTORLINUX 7.0 RC2.1 Bug Reports
« Reply #48 on: October 09, 2011, 05:18:36 pm »
Gslapt says hplip ver 3.10.2-i586-2vl70.

But I don't think I am using hplip.  I am using cups.  perhaps that is the problem.  But I doubt it.  I am pretty sure that the new slackware kernel just doesn't support usb printer input on some of the not-so-old hp laserjets.

John

That's the "good" version of hplip. The kernel only sees it as usb, and cups/hplip pickup the tab from there. Its up to cups/hplip to do anything printer-specific at that point. Try doing the hplip configuration for cups
pierce.jason
Email: $(echo -e "moc\x2eliamg\x40nosaj.ecreip" | rev)

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: VECTORLINUX 7.0 RC2.1 Bug Reports
« Reply #49 on: October 10, 2011, 03:03:00 pm »
Quote
The kernel only sees it as usb

I think that's my problem.  The kernel doesn't see anything when I plug my HP laserjet 4Mplus into the usb port.  Nor does it see my HP laserjet 6MP.  Tried different cables.  If it would see it, I could configure it.  As it is, I have to use the parallel port, which is kind of slow.

JOhn
VL7.0 xfce4 Samsung RF511

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4073
Re: VECTORLINUX 7.0 RC2.1 Bug Reports
« Reply #50 on: October 10, 2011, 04:46:41 pm »
If you watch the messages (tail -f /var/log/messages) when you plug in the printer, do you see anything?

I had an HP printer years back, remember I had to use "hp-makeuri" to get it working.. that still the case?

scififry

  • Member
  • *
  • Posts: 66
Re: VECTORLINUX 7.0 RC2.1 Bug Reports
« Reply #51 on: October 12, 2011, 02:18:30 am »
As it is, I have to use the parallel port, which is kind of slow.
Have you set your parallel port to ECP (Extended Capabilities Port) in the BIOS? If your printers support that, it'd speed data transfer up to 1.5MB/s.

pierce.jason

  • Packager
  • Vectorite
  • ****
  • Posts: 250
Re: VECTORLINUX 7.0 RC2.1 Bug Reports
« Reply #52 on: October 13, 2011, 09:40:21 pm »
Quote
The kernel only sees it as usb

I think that's my problem.  The kernel doesn't see anything when I plug my HP laserjet 4Mplus into the usb port.  Nor does it see my HP laserjet 6MP.  Tried different cables.  If it would see it, I could configure it.  As it is, I have to use the parallel port, which is kind of slow.

JOhn

What I meant, is the kernel is supposed to only care if it USB in the case of printers. The rest is done by cups and hplip.

lsusb should list all devices that the kernel sees as USB. See if your printer is listed there. This will confirm that the USB port on your printer is functioning correctly.

And as nightflier mentions, there's a command like hp-makeuri that you'll need to run to give the correct info to cups. This is one area that we really need updated documentation on, I can't remember the specifics of what needs to be done here to get hplip and cups to run together. Maybe some generic hplip/cups documentation has the needed info?
pierce.jason
Email: $(echo -e "moc\x2eliamg\x40nosaj.ecreip" | rev)

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: VECTORLINUX 7.0 RC2.1 Bug Reports
« Reply #53 on: October 15, 2011, 07:07:04 am »
Thanks for the help with my HP printing situation.   In thinking about all this, I forgot to emphasize that I changed laptops at the time I switched to VL 7.

I just tried printing to my home HP LaserJet4 from my new laptop (computer and VL stats below). 

It worked.

 Here are details. 

I connected it to the usb slot on the left of this laptop (when facing).  This is what I have traditionally done as I have the right two usb ports connected to other stuff.

Cups (or whatever) did not find the printer.

I freed up on of the USB ports on the right side of the machine.  Cups found the printer.

The usb ports on the left, which work for, say, my mouse, apparently have different specs than the usb ports on the right. 

I will try this at the office and if that doesn't also work there, post the forum.  Else, my printing problem is solved. 

thanks again

VL7.0 xfce4 Samsung RF511

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: VECTORLINUX 7.0 RC2.1 Bug Reports
« Reply #54 on: October 28, 2011, 12:24:38 pm »
I still think there is a problem with Cups 1.4.6 or VL 7 rc2.  It won't see my Xerox copier which I want to use to print wireless.  Perhaps this is fixed in the latest RC.  Hope so.  I can get on the copier, typing its url, so I know something is working.

"Add Printer" doesn't see it the Xerox even though I am on the Xerox' URL.  I have to go to Internet Printing Protocol (Http) and put it in there.  Then I can print with it and Cups sees it in "manage printers."

John
VL7.0 xfce4 Samsung RF511