VectorLinux
October 22, 2014, 08:55:24 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: OpenOffice Update Issue  (Read 2448 times)
Martin109
Vectorite
***
Posts: 290


« on: September 08, 2011, 06:20:02 am »

I have installed OpenOffice.org on my VL6 machines, and the whole suite of components to this.  I would like to be able to update it, as I do regularly with Firefox and Thunderbird.  However, there is no option under 'Help' in the OpenOffice.org menu to do this.

The Help file suggests that updating is performed by an optional module:

“Online Update is a module that can be selected or deselected to be installed. Choose the customized installation in the Setup of OpenOffice.org.”

but using the Gslapt Package Manager to install does not give the option to customize installation, as it's done automatically.

Also, if I look under Gslapt, under 'OpenOffice', I get the following 'Installed' listing:

OpenOffice         2.4.0.8-i586-4gsb
OpenOffice-perl      2.008-i586-2gsb
OpenOffice.org      3.1.0.6-i586-2vl60

This suggests that there are two versions installed.

When I check on the OpenOffice Writer 'Help' menu as I compose this, it tells me it's v2.0.4.8

Should I uninstall 2.0.4.8 and reinstall 3.1.0.6?

Will that give me an update option?
« Last Edit: September 08, 2011, 06:26:36 am by Martin109 » Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
pierce.jason
Packager
Vectorite
****
Posts: 250



« Reply #1 on: December 07, 2011, 10:55:25 am »

If you want to use OO's built-in updater, I'd suggest uninstalling all VL OO packages and using the installer from OO website. This will most likely place it into /opt and allow for "clean" self contained updates. You might want to checkout LibreOffice while you're at it, it seems that most developers from OO have moved to the LibreOffice project.
Logged

pierce.jason
Email: $(echo -e "moc\x2eliamg\x40nosaj.ecreip" | rev)
Martin109
Vectorite
***
Posts: 290


« Reply #2 on: December 07, 2011, 01:47:46 pm »

You might want to checkout LibreOffice while you're at it, it seems that most developers from OO have moved to the LibreOffice project.

Thank you!  I had no idea of these developments - I'll have a close look at LibreOffice.
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
furydragon
Member
*
Posts: 26


« Reply #3 on: December 07, 2011, 04:57:48 pm »

Built-in updater was deleted during repack. You can find repack script for slackware (similar distro) on http://slackbuilds.org/.

So, you can three opportunities:
1) install OO from official web site (but there aren't packages for slackware's family distro, other distros have different system path. So official package need repack or good luck with default installation  Wink)
2) install updater manually (unpack installer from OO web site, there are updater package);
3) migrate to LibreOffice.

Quote
Sometimes buit-in updater deletes from Firefox and Thunderbird.
Logged
Martin109
Vectorite
***
Posts: 290


« Reply #4 on: December 08, 2011, 03:02:25 am »

Is it possible to access LibreOffice from the VL7.0 repo, while still sticking with VL6.0 for the time being.

I don't want necessarily to upgrade to VL7.0 on my 4 Linux laptops just yet!
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
pierce.jason
Packager
Vectorite
****
Posts: 250



« Reply #5 on: December 08, 2011, 11:28:33 am »

Might be, but it won't be a trivial task. You'll have to ignore dependency versions and manually install a few deps probably.

Here's the minimal versions acceptable for 3.4.4 as listed on libreoffice.org
Code:
Linux kernel version 2.6.18 or higher;
glibc2 version 2.5 or higher;
gtk version 2.10.4 or higher;
gail 1.8.6;
at-spi 1.7;
Logged

pierce.jason
Email: $(echo -e "moc\x2eliamg\x40nosaj.ecreip" | rev)
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!