VectorLinux
September 16, 2014, 05:05:30 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: HOWTO use "slapt-get" for packages  (Read 21158 times)
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« on: July 24, 2006, 03:00:02 pm »

slapt-get is easy!
==================

[this post was originally written by lagagnon here : http://www.vectorlinux.com/forum1/index.php?topic=6331.0]

slapt-get is a very easy command line program to help you install, remove and upgrade VectorLinux and/or Slackware packages.

The Slackware packaging system is an excellent one and slapt-get makes it even easier. Do not be afraid of the command line. We should be so lucky that slapt-get has very few switches, is easy to learn and is MUCH easier to use than Red Hat's RPM system. For instance, check out the slapt-get man page ("man slapt-get"): it is only two pages long. That is very short by man page standards and suggests that it really is an easy piece of software to use.

slapt-get is essentially a command line based "wrapper" around the Slackware pkgtools commands (installpkg, removepkg, upgradepkg), but with a lot more functionality and automation that mimics the Debian apt packaging tools. "gslapt"  is a GUI wrapper around slapt-get - nothing more, nothing less. Please note that the old VL packaging menu system VLAPT has been deprecated by slapt-get and gslapt.

There are only four "gotchas" to be aware of with slapt-get:

1) before doing anything you must have a valid /etc/slapt-get/slapt-getrc configuration file. On a new VL install it should be fine.
2) the command "--upgrade" upgrades EVERY installed package on your system for which there is a more recent version. Do you REALLY need to do that? It can be dangerous.
3) if you seem to be getting errors or nothing appears to be happening run "slapt-get --clean"
4) only properly packaged slapt packages will check for dependancies.

My personal bug-bear with some Linux users is that there seems to be this almighty desire to always be at the bleeding edge of software upgrades. Why? Unless there is a serious bug or serious security hole in the package or you absolutely require newer functionalities why would you be willing to take a chance with problems by upgrading unnecessarily? As much effort as the programmers and packagers put into new packages, there will always be the odd case of inconsistency or breakage. That is inevitable. It is an issue on every operating system. Do you really want to upgrade every package in your system and suffer the consequences, or are you a masochist? IMHO it would be better to await the next stable release of Vector and reinstall. That is my little diatribe warning about "slapt-get --upgrade" . Now onto the good stuff:

slapt-get automates the download and installation of Slackware/Vector packages and thus it needs to know where to get them: thus the config file:/etc/slapt-get/slapt-getrc. This file in VectorLinux 5 is all ready for you to edit. All you need to do is uncomment the SOURCES you wish to download from, e.g. in part:

# Vector Linux mirrors
SOURCE=ftp://ibiblio.org/pub/linux/distributions/vectorlinux/veclinux-5.0/packages
SOURCE=ftp://ftp.nluug.nl/pub/metalab/distributions/vectorlinux/veclinux-5.0/packages
#SOURCE=ftp://ftp-linux.cc.gatech.edu/pub/linux/distributions/vectorlinux/veclinux-5.0/packages/
#SOURCE=ftp://public.planetmirror.com.au/pub/vectorlinux/veclinux-5.0/packages/

Note I have chosen only the first two mirrors. You can also uncomment the Slackware sites and/or the linuxpackages.net site. Be aware that the packages specifically packaged for VL should be your first choice and Slackware ones secondary. If you choose Slackware packages they will not check for dependancies.

By default VL5 uses as its "working directory" (local storage/cache): /home/ftp/pub/veclinux-5.0/packages/. This is already set up in the config file for you. Now you are done basic setup.

The next step is retrieve the package data from the mirror sites you chose in the config file. This will produce a listing in your working directory of all available packages (NOTE slapt-get must be run as root):

slapt-get --update    (NOT --upgrade!) This command can take a few seconds to a few minutes depending on how many mirror sites you're checking.


To list packages you already have installed:            slapt-get --installed
To list packages which are now available to you:    slapt-get --available
To show a packages complete description:
      slapt-get --show [package(s)]
To search for a package in your list:
      slapt-get --search [package(s)]


Now to install a specific package:   
        slapt-get --install [package(s)]
where [package(s)] can be a package name or package name with version number. If you are a bit unsure of yourself before doing the "install" step do this:

slapt-get -s --install [package(s)]

this simulates the install process without actually doing anything. You can also use "-s" to simulate an upgrade.

If an install borks your system or you decide you don't need the software any longer remove the package with:

slapt-get --remove [packages(s)]

Again, you have to be a cowboy or a masochist (IMHO) but if you want to upgrade all your installed packages with any available newer packages:

slapt-get --upgrade

(you have been warned of the possible consequences).

To download a package to your working directory without upgrading or installing it:

slapt-get --download-only --install [package(s)]

Once in a while you should clean up downloaded files from your working directory:

slapt-get --clean

That is about it. There are a few other options I won't discuss here. Feel free to "man slapt-get" and to read the FAQ at http://software.jaos.org/BUILD/slapt-get/FAQ.html .


have fun....Larry
« Last Edit: November 09, 2006, 10:58:11 pm by lagagnon » Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!