Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: PPP and KPPP help  (Read 3145 times)


  • Member
  • *
  • Posts: 9
PPP and KPPP help
« on: October 12, 2011, 06:54:37 am »

I just installed V.L. 6.0  KDE and am trying to set up dial-up networking.
    I may have messed up here.   I first went to vasm and set up PPP.   Then, I went to my desktop and set up KPPP to dial out, and the modem dials and then tells me it's connecting, but then the modem drops the connection and redials, over and over, but never connects. 
     Did I make a mistake by first setting up PPP?   Will this interfere with KPPP use?   If so, how do I undo the PPP setup?   
    When I set up KPPP ( I did this before on other systems, Slackware-MEPIS,etc, but forget the exact details) so see if I have it right:
I used the manual setup, not the Wizard.   Dial>connection name>XXXXX
Add phone number:  XXX-XXXX
Authentication:  PAP  (I also tried CHAP and PAP/CHAP)   Is PAP the right one?  None of them worked to sucessfully dial out. 
Store password:   ...
IP>Configuration>Dynamic IP address
Gateway:  Configuration>Default gateway
Assign the default route to this gateway.
DNS:  Domain name?   I left this blank.   Should I put something here?
Configuration:  automatic
Device name:  U.S. Robotics  (Actiontek the first time)
modem device:  /dev/ttyS0
Flow Control:  Hardware  [CRTSCTS]
Line termination:  CR
Connection speed:  115200
  I did not use the lock file
Modem time out: 60 sec
Modem>wait for dial tone before dialing
Busy wait:  0 sec

    Does anyone see what the heck I managed to do wrong?    :-[


  • Administrator
  • Vectorian
  • *****
  • Posts: 3497
Re: PPP and KPPP help
« Reply #1 on: October 12, 2011, 07:31:34 am »

In Vectorlinux, run
Code: [Select]
pppoe-setup as root in a terminal


  • Vectorite
  • ***
  • Posts: 156
  • Just me.
Re: PPP and KPPP help
« Reply #2 on: October 12, 2011, 02:42:05 pm »

I'm on dialup,...
and when I am using KDE (and KPPP)...I always have to go to terminal, and type:
  su <enter>
  root's password <enter>
  touch /etc/resolv.conf  <enter>
  touch /etc/ppp/options   <enter>  

In some distros (can't remember about Vector KDE) there also is a file you have to configure,......(as root)

*try the first two files, (touch /etc/resolv.conf --  touch /etc/ppp/options)  and then setup the KPPP and see if that does it.  KPPP won't work without setting up the /etc/resolv.conf.

EDIT:  I have the Vector KDE Classic CD,...and I will go install it on another computer right now.  I'll set up the dialup thingy,..and get back to you (if you haven't got things working by then.)
« Last Edit: October 12, 2011, 02:48:47 pm by nitehawk »


  • Vectorite
  • ***
  • Posts: 156
  • Just me.
Re: PPP and KPPP help
« Reply #3 on: October 12, 2011, 03:26:25 pm »

I have Vector 6 KDE Classic up and running.  I'm on KPPP and my dialup right now...
All I did was to go to terminal,...and (as root) type in those two lines.
  touch /etc/resolv.conf  <enter>
  touch /etc/ppp/options <enter>

Then I setup KPPP (added my ISP info,...modem info,..etc. etc.)

...and that was it !!!  

EDIT:  Hey,...I forgot how much fun Vector 6 KDE Classic is,....I'm off to go for a "drive" in it, around the web,.....
« Last Edit: October 12, 2011, 03:59:59 pm by nitehawk »