VectorLinux
October 01, 2014, 04:04:00 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: PPP and KPPP help  (Read 1200 times)
frogzz
Member
*
Posts: 9


« on: October 12, 2011, 05:54:37 am »

I just installed V.L. 6.0  KDE and am trying to set up dial-up networking.
    I may have messed up here.   I first went to vasm and set up PPP.   Then, I went to my desktop and set up KPPP to dial out, and the modem dials and then tells me it's connecting, but then the modem drops the connection and redials, over and over, but never connects. 
     Did I make a mistake by first setting up PPP?   Will this interfere with KPPP use?   If so, how do I undo the PPP setup?   
    When I set up KPPP ( I did this before on other systems, Slackware-MEPIS,etc, but forget the exact details) so see if I have it right:
I used the manual setup, not the Wizard.   Dial>connection name>XXXXX
Add phone number:  XXX-XXXX
Authentication:  PAP  (I also tried CHAP and PAP/CHAP)   Is PAP the right one?  None of them worked to sucessfully dial out. 
Store password:   ...
IP>Configuration>Dynamic IP address
Gateway:  Configuration>Default gateway
Assign the default route to this gateway.
DNS:  Domain name?   I left this blank.   Should I put something here?
Configuration:  automatic
Modems>New
Device name:  U.S. Robotics  (Actiontek the first time)
modem device:  /dev/ttyS0
Flow Control:  Hardware  [CRTSCTS]
Line termination:  CR
Connection speed:  115200
  I did not use the lock file
Modem time out: 60 sec
Modem>wait for dial tone before dialing
Busy wait:  0 sec

    Does anyone see what the heck I managed to do wrong?    Embarrassed
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3180



« Reply #1 on: October 12, 2011, 06:31:34 am »

In Vectorlinux, run
Code:
pppoe-setup
as root in a terminal
Logged

nitehawk
Vectorite
***
Posts: 155


Just me.


« Reply #2 on: October 12, 2011, 01:42:05 pm »

I'm on dialup,...
and when I am using KDE (and KPPP)...I always have to go to terminal, and type:
  su <enter>
  root's password <enter>
  touch /etc/resolv.conf  <enter>
  touch /etc/ppp/options   <enter>  

In some distros (can't remember about Vector KDE) there also is a file you have to configure,......(as root)
/etc/ppp/peers/provider

*try the first two files, (touch /etc/resolv.conf --  touch /etc/ppp/options)  and then setup the KPPP and see if that does it.  KPPP won't work without setting up the /etc/resolv.conf.

EDIT:  I have the Vector KDE Classic CD,...and I will go install it on another computer right now.  I'll set up the dialup thingy,..and get back to you (if you haven't got things working by then.)
« Last Edit: October 12, 2011, 01:48:47 pm by nitehawk » Logged
nitehawk
Vectorite
***
Posts: 155


Just me.


« Reply #3 on: October 12, 2011, 02:26:25 pm »

OK,..
I have Vector 6 KDE Classic up and running.  I'm on KPPP and my dialup right now...
All I did was to go to terminal,...and (as root) type in those two lines.
  touch /etc/resolv.conf  <enter>
  touch /etc/ppp/options <enter>

Then I setup KPPP (added my ISP info,...modem info,..etc. etc.)

...and that was it !!!  

EDIT:  Hey,...I forgot how much fun Vector 6 KDE Classic is,....I'm off to go for a "drive" in it, around the web,.....
« Last Edit: October 12, 2011, 02:59:59 pm by nitehawk » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!