Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: problem with keyboard and mouse  (Read 2619 times)


  • Member
  • *
  • Posts: 1
problem with keyboard and mouse
« on: March 25, 2012, 01:32:27 pm »

I've just installed Vector Linux 7 Light to my old computer and I have a strange problem with my keyboard and my mouse. When it comes to the screen where I have to type in my username and password, my keyboard doesn't work, nor does my mouse. both are ps/2. what could be the problem? keyboard works in the bios and in Lilo, I can select what to boot, after that it's like dead.. help please


  • Vectorite
  • ***
  • Posts: 135
Re: problem with keyboard and mouse
« Reply #1 on: April 27, 2012, 10:00:36 am »

I have a white box PC built by before they drove themselves out of business.  It was one of the systems advertised on the VL websites and it came with VL 5.8 pre-installed.  I had purchased it for my daughter when she was still in school.  I did replace VL 5.8 Standard with VL 6.0 Light.  When VL 7.0 standard came along I attempted to install it as a replacement for VL 6.0 Light. 

VL 7.0 installer does not recognize the PS/2 keyboard.  Installation fails for that reason.

The computer has a MSI motherboard with an Intel Celeron D 2.8GHz processor (I did not order it with this processor but that is how it was shipped), 1GB of PC2-5300 RAM, a 15GB ATA HDD, CD-R, standard PS/2 mouse and keyboard and the usual assortment of usb, parallel and serial ports.  The system has not been altered in any way other than to upgrade the RAM from 512MB to 1GB. 

I wound up re-installing VL 6.0 Light and upgrading Firefox and Flashplayer to current versions so that she can continue to use the PC (as she has grown rather fond of VL).

Custom Mini-Itx - VL6.0 Light


  • Administrator
  • Vectorian
  • *****
  • Posts: 4155
Re: problem with keyboard and mouse
« Reply #2 on: April 27, 2012, 01:22:53 pm »

There was a similar thread a few weeks ago. Turned out that the keyboard was plugged in to the mouse port and vice versa. Worth looking at.