VectorLinux
November 20, 2014, 02:47:38 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Fresh Install of VL7.0, Login and Thunar....  (Read 713 times)
ElEdwards
Member
*
Posts: 34


« on: December 04, 2011, 02:31:51 am »

What a great distro this is!!  I used VL up until 6.0 but had audio issues with it, so went back to Mint.... but now with the release of VL7.0, I'm back and lovin' life!!

Three questions:
1- What is the best method to use to make certain the username I defined in setup is ALWAYS the default user at bootup without a Chooser?

2- After I first boot and things settle down, my first use of Thunar takes almost a minute to open up....but after that first start of the app, subsequent starts in the same session are fast!  What can I do to make the first start of the Thunar app quicker?

3- I tried to install (using VSlapt) PCManFM but it simply won't start.  What could I have missed in trying to install it.  (I'd like to use it so I can right-click on a file and make it executable, which I can't find a way to do in Thunar.)

Thanks again for the great work!!

El
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: December 04, 2011, 04:33:59 am »

What a great distro this is!!  I used VL up until 6.0 but had audio issues with it, so went back to Mint.... but now with the release of VL7.0, I'm back and lovin' life!!

Three questions:
1- What is the best method to use to make certain the username I defined in setup is ALWAYS the default user at bootup without a Chooser?
Settings --> Login Window -->Security Tab ... " Enable Automatic Login.

2- After I first boot and things settle down, my first use of Thunar takes almost a minute to open up....but after that first start of the app, subsequent starts in the same session are fast!  What can I do to make the first start of the Thunar app quicker?
This is normal behaviour for Thunar in xfce4.8.x.  At first boot it checks with the Avahi Daemon and does other steps to set up networking.
This is why there is now a Network tab in the side panel of the file manager window.
Instead of shutting the computer down each time, why not try suspending it instead.  You won't have to wait for a long boot-up or wait for Thunar either.


3- I tried to install (using VSlapt) PCManFM but it simply won't start.  What could I have missed in trying to install it.  (I'd like to use it so I can right-click on a file and make it executable, which I can't find a way to do in Thunar.)
PCManFM may be a repository issue I'll look into it. 
To make a program executable in thunar, just right click on the file-->Properties-->Permissions(Tab)-->Click the box that says allow this file to run as a program.

Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #2 on: December 04, 2011, 04:45:48 am »

re: pcManfm
Yup there is an issue.  Here is a fix until it can be repackaged.
In the terminal as root enter the following.

Search libfm in gSlapt and downgrade to version 0.1.14.

I'll remove version libfm version 0.1.16, until it can be rebuilt.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
hata_ph
Packager
Vectorian
****
Posts: 3259


-- Just being myself --


« Reply #3 on: December 04, 2011, 07:52:20 am »

can you try to run pcmanfm from terminal and let me know the error message...
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #4 on: December 04, 2011, 08:09:28 am »

Did a little more digging.
pcmanfm 0.9.8 is in extra, as well as all the libfm's.
pcmanfm 0.9.9 is in testing.

My guess now is that ElEdwards, did not have testing enabled (the default set-up) and installed pcmanfm.
This gave him a mix of the old pcmanfm plus the new libfm and they were not compatible.
That would explain why the downgrade to the old libfm fixed it for me.

I have moved the new pcmanfm to extra as well, now. So if I'm right (sometimes that's a big if.) The problem should be solved.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
ElEdwards
Member
*
Posts: 34


« Reply #5 on: December 04, 2011, 01:10:49 pm »

Ah...got the autologin set up Smiley  Thanks.

...and I just realized that I can open Terminal, use "su -", open Thunar on the CL and then I can change file properties as root.

I'm not always quick.... but I'm thorough Wink

Thanks!!
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!