Please support VectorLinux!

Author Topic: [SOLVED] Boot Broken  (Read 16786 times)

Pita

  • Vectorian
  • ****
  • Posts: 1324
[SOLVED] Boot Broken
« on: December 14, 2011, 10:23:10 pm »
When I tried to boot this morning the machine halted with the following error:

Code: [Select]
fb: conflicting fb hw usage nouveaufb vs VESA VGA - removing generic driver

I tried to make a rescue booting with VL7 disk. When it comes to opening X, system hangs. Keyboard cannot be accessed and screen is blank.

I have not made any upgrade or other fumbling lately.

I can boot from the live disk where I am in now.

Hope there is help!
« Last Edit: December 15, 2011, 06:30:09 pm by Pita »

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: Boot Broken
« Reply #1 on: December 14, 2011, 10:43:39 pm »
Have you tride running vxconf to reset graphics driver and xorg.conf?  I don't know if that's the fix, but it's the first thing I would try.
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

Pita

  • Vectorian
  • ****
  • Posts: 1324
Re: Boot Broken
« Reply #2 on: December 14, 2011, 11:34:47 pm »
Have you tried running vxconf to reset graphics driver and xorg.conf?  I don't know if that's the fix, but it's the first thing I would try.


I surely thought of that. Problem is how to get into my box.

BTW this is affecting both of my drives with 2 different Linux distros one of them VL7.

From the Live CD I can access all of my partitions, therefore I don't think it is a HD problem.

Pita

  • Vectorian
  • ****
  • Posts: 1324
Re: Boot Broken
« Reply #3 on: December 15, 2011, 04:00:34 am »
Setting inittab to 2 via the live CD I am now able to log into my box of VL7. Doing
 vxconf it seems that I cannot anymore use the display setting of 1280x1024
which is the correct one for my 19" LCD. That settings hangs now the system.
1024x768 is working, however, naturally too large.
I am using an external video card. May that is the problem. Will check tomorrow
if the onboard card is working.

bigpaws

  • Vectorian
  • ****
  • Posts: 1868
Re: Boot Broken
« Reply #4 on: December 15, 2011, 06:37:06 am »
According to that the nouveafb is loading
you can blacklist that and give it a test.

You should be able to blacklist it here:

/etc/modprobe.d/nouveau.conf


Bigpaws

Pita

  • Vectorian
  • ****
  • Posts: 1324
Re: Boot Broken
« Reply #5 on: December 15, 2011, 06:32:50 pm »
Thanks all!

It was after all the graphic card. I gave it a good cleaning including
contacts, fan etc and it is working now.

To play safe I will get a spare.
« Last Edit: December 15, 2011, 06:44:34 pm by Pita »