Author Topic: v7 - migration desktop & keyboard issues  (Read 2592 times)


  • Member
  • *
  • Posts: 6
v7 - migration desktop & keyboard issues
« on: December 26, 2011, 11:37:45 am »
Have just installed v7 from v6 Deluxe and seemed to go smoothly.

However 2 issues, when I migrated my existing user account on my /Home, on the first startup it asked something about if I wanted to migrate the desktop toolbar or create a new one, and I chose Migrate. However, the menus & bars are now mostly empty with a lot of the application icons having an x on them and missing. Just wondering if there is a way to undo this and perhaps install the new v7 toolbar instead? I don't mind even if it means I have to try reinstalling the system again.

The other is difficulty setting up the keyboard layout to dvorak. In version 6 this was already offered during the installation. I have tried going to Vasm - XWindow - xkbset, but then gives an error message: Cannot find X11 keymap list.

Any help for these issues would be greatly appreciated, thank you.


  • Member
  • *
  • Posts: 6
Re: v7 - migration desktop & keyboard issues
« Reply #1 on: December 26, 2011, 03:52:36 pm »
I tried renaming the ./config/xfce4 directory and then reinstalling. It seemed to reset something, as when I logged in the user for the first time after the reinstall, it gave me the following option again:
Welcome to the first start of the panel. Choose below which setup you want for the first startup
Migrate old config
Use default config
One empty panel

I had used the "Migrate old config" the first time which gave the original problem. This time I chose "Use default config" which now puts the menu bar at the top instead of at the bottom, but many of the menu options are still missing icons. In addition, the old xfce panel is still at the bottom.

Should also add that the first time I installed (using the Migrate old config), the desktop was just a plain black background, and then when renaming the ./config/xfce4 directory and reinstalling, then choosing the "Use default config", the background is now gray and with the xfce logo rather than any Vectorlinux logo, in case that provides a clue as to what might be happening.

Do you know of any other place where these settings might be able to be removed and reset?

In the meantime though, I've managed to solve the keyboard issue:
For running a Dvorak keyboard, when configuring XCONF during the setup, do NOT use the Auto (xorg with NO xorg.conf) option. Instead, can use the VXconf option, and then manually edit /etc/X11/xorg.conf and add
Option  "XkbVariant"  "dvorak" underneath the line that has the XkbLayout
« Last Edit: December 26, 2011, 04:14:31 pm by yac »