Please support VectorLinux!

Author Topic: [Solved] VL6 light and Tenda W311U problems  (Read 5919 times)

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: VL6 light and Tenda W311U problems
« Reply #15 on: January 06, 2012, 01:59:23 pm »
Wicd has two parts. The server needs to be started by root. Accomplish this by using the terminal:
Code: [Select]
su
<password>
which wicd
This will tell you where wicd is located, don't remember if it's /sbin/wicd or elsewhere. Continue with:
Code: [Select]
mcedit /etc/rc.d/rc.localAdd a line to the end of the file containing the location of wicd. F2 to save, F10 to exit.

Next, the client. Do this as a regular user, not root. In your home folder, there is a hidden folder ".icewm". Inside it is a file named "startup". I think there should be a line about wicd-client that has been commented out (has a leading #). If so, just remove the # and it should automatically launch on start. If not, add a line: "wicd-client".

fh67

  • Member
  • *
  • Posts: 23
Re: VL6 light and Tenda W311U problems
« Reply #16 on: January 07, 2012, 04:12:10 am »
That seems to work, nightflier, thank you!  :) I had to add the line in 'startup'  for the client completely from scratch. The wicd location was /usr/sbin/wicd.

There does now appear to be a minimized window  that sits in the top-left of the screen on startup. When expanded it is just grey and has no contents - it has no name, but when I listed all the windows that are open it says it is pcmanfm. This  window  cannot be closed.  Any ideas why this is happening?

I still haven't found a way to select automatic login for VL6 Light itself.

Many thanks again,

FH67
« Last Edit: January 07, 2012, 04:39:39 am by fh67 »

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: VL6 light and Tenda W311U problems
« Reply #17 on: January 07, 2012, 07:20:04 am »
I forgot: you need a "&" after the wicd-client command, like this:
Code: [Select]
wicd-client &
Some times, that little window is a result of programs starting out of sequence. If problem remains, introduce a delay before loading wicd-client, like this:
Code: [Select]
sleep 3
wicd-client &
You may need to play with the delay time (it is in seconds).

Autologin: Assuming you did install KDM, there should be a Menu entry System > KDM Setup.


nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: VL6 light and Tenda W311U problems
« Reply #18 on: January 07, 2012, 07:28:38 am »
You may want to add a volume control to the panel.
First, use gslapt and install program "obmixer". Then add another entry to the startup file:
Code: [Select]
sleep 3
obmixer &
This is one that usually needs a little delay. It depends on the computer, experiment with different values.

Of course, every program running in the background consumes some memory and CPU cycles. However, if this computer is intended for someone not familiar with Linux, you may get complaints about "missing pieces".

fh67

  • Member
  • *
  • Posts: 23
Re: VL6 light and Tenda W311U problems
« Reply #19 on: January 07, 2012, 09:00:17 am »
Thank you - mostly success to report.  :o

The mysterious black box has disappeared after experimenting with sleep periods, the wireless connects automatically and there's a nice volume icon on the taskbar. That's great.  :)

The autologin for Linux still doesn't work. I selected autologin for the user (my friend's name - there's also a vl user in that list) and it says ok, it accepted that - but it still pops up the "Welcome to vector1.net" (or whatever it says at logon) and asks for a user and password. I think it's going to have to stay like that if the alternative involves installing more programs that will slow the computer down and use memory.  :-\

You know your stuff, nightflier. Thanks again.

Oh, is there also a way of stopping the voice soundfile playing when shutting down or rebooting the computer? I disabled (hashed out) the startup one because I saw it in the file I needed to alter.

Regards,

FH67

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: VL6 light and Tenda W311U problems
« Reply #20 on: January 07, 2012, 10:02:20 am »
Easiest way to disable the startup/shutdown sounds is to just delete the wave files in ~/.icewm/sounds

Now, you've done a nice job solving issues and we're so close, it would be a shame to stop before your system is perfect..  ;D  Enabling autologin will not slow your system down. You say you found the KDM Setup entry on the menu, and it did run, asking for root password and giving you the option of enabling/disabling autologin or change image?

fh67

  • Member
  • *
  • Posts: 23
Re: VL6 light and Tenda W311U problems
« Reply #21 on: January 07, 2012, 11:01:37 am »
Right, the final hurdle then!  8)

I've renamed the sound files, instead of deleting them.

On startup I get a very crude (and huge) login screen that says, "Welcome to vector.1.net" and asks for the login and password. No user names or options are mentioned. This is the same as it has always been.

I selected System > KDM Setup.
The computer asks for the root password.
It then says, "What do you want to change?" and the options are "Enable autologin", "Disable autologin" and "Change login picture".
After selecting the enable autologin option, it asks, "Who should be logged in utomatically?" The options are "VL" and my friend's name.
I selected my friend's name, clicked the 'ok' button and the computer responds with, "Autologin configured for user name

However, doing the above doesn't change anything.

Strange, eh?

FH67

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: VL6 light and Tenda W311U problems
« Reply #22 on: January 07, 2012, 11:29:04 am »
I believe you are looking at XDM. Did you install the Live or the traditional version?

fh67

  • Member
  • *
  • Posts: 23
Re: VL6 light and Tenda W311U problems
« Reply #23 on: January 07, 2012, 12:41:57 pm »
Installed from a VL6 Light Live cd.

XDM?  ???

I definitely clicked on System>KDM setup.

HTH,

FH67




fh67

  • Member
  • *
  • Posts: 23
Re: VL6 light and Tenda W311U problems
« Reply #24 on: January 07, 2012, 12:44:50 pm »
Just looked up XDM on Wikipedia - yes, that's the login screen I see on startup.

FH67

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: VL6 light and Tenda W311U problems
« Reply #25 on: January 07, 2012, 02:46:34 pm »
Quick and dirty way to do this: install kdm-small using gslapt, reboot and run KDM-Setup again.

fh67

  • Member
  • *
  • Posts: 23
Re: VL6 light and Tenda W311U problems
« Reply #26 on: January 08, 2012, 03:15:13 am »
Interesting.

Does KDM use more resources than XDM and, if so, does it continue to do so after login? In other words, will it replace XDM as the permanent display manager? I ask because after upgrading to the latest Firefox (didn't get round to upgrading Opera, though it seemed a bit faster than Firefox) the computer has slowed a little and if the choice is between a one-time-per-session clumsy login screen or automatic login but slower overall performance, I would probably let things remain as they are. Better to know now than install kdm-small and not be able to backtrack.

FH67

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: VL6 light and Tenda W311U problems
« Reply #27 on: January 08, 2012, 05:22:44 am »
The impact on performance will be negligible, and reversable with command "removepkg kdm-small".

If you want to boost performance, you would gain a lot more by turning off desktop icons and wallpaper (in pcmanfm preferences). If the computer will be stationary, you can configure wi-fi manually and get rid of wicd. Undo the steps we did to get it running, then run command "VLwifi" as root. You can even bypass the desktop manager by setting machine to boot to command line and starting X manually.
« Last Edit: January 08, 2012, 05:24:44 am by nightflier »

fh67

  • Member
  • *
  • Posts: 23
Re: VL6 light and Tenda W311U problems
« Reply #28 on: January 08, 2012, 07:39:50 am »
Gslapt finds 2 entries called kdm-small:

kdm-small 3.5.9-i586-1vl60, location kde, "A special kdm package created for VL-5.8-std"  (not installed)

kdm-small 3.5.10-i586-2vl60, no location, "A special kdm package created for VL-5.8-std"  (installed)

Text in the 'Common' tab regarding the installed ...2vl60 version  says that the latest available version is 3.5.9-i586-1vl60. Is that right, as it seems counterintuitive?

So it appears the ...2vl60 version is already installed on this laptop - but it doesn't seem to do anything, not like it is meant to.

I only have 3 desktop icons on this machine, wallpaper the recipient wanted and I think those other measures would make the machine unusable for her, but thanks for the information.

Regards,

FH67
« Last Edit: January 08, 2012, 07:51:36 am by fh67 »

fh67

  • Member
  • *
  • Posts: 23
Re: VL6 light and Tenda W311U problems
« Reply #29 on: January 08, 2012, 07:48:42 am »
In addition to the above, when clicking on the ...1vl60 version to install it, the only option that comes up is to "Downgrade".

Also, for the ...2vl60 version, it says the installed size is 0K, but clicking on the box you use to install packages, it only offers 'Remove' as an option.

So, despite the text saying the latest available version is the ...1vl60 version, Gslapt also says that the ...1vl60 version would be a downgrade and that ...2vl60 is installed,yet occipies no size at all.

Something's wrong somewhere.  ???

FH67
« Last Edit: January 08, 2012, 07:52:50 am by fh67 »