Please support VectorLinux!

Author Topic: Blank screen after suspend  (Read 4936 times)

|nic|

  • Packager
  • Vectorite
  • ****
  • Posts: 162
    • My Blog
Blank screen after suspend
« on: January 03, 2012, 11:15:32 am »
Hi,

I installed VL 7 standard on my netbook. Everything works but when i'm trying to get my netbook out of suspend all i get is a blank screen.
any suggestions how to fix that?

cheers

nicdm
registered user #393337

Desktop AMD E6 / 8 gb ram / 120 GB SSD / 500 gb HD / VL7

Samsung NP110 / VL7.1 Std

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: Blank screen after suspend
« Reply #1 on: January 03, 2012, 11:29:18 pm »
Nope, but I will watch this thread with interest.  When I come out of a long suspend my computer doesn't act right either.

VL7.0 xfce4 Samsung RF511

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: Blank screen after suspend
« Reply #2 on: January 04, 2012, 10:50:04 am »
Have you tried keying Ctrl+Alt+F1, followed by Ctrl+Alt+F7? This fixes a blank screen at the gdm login that sometimes happens on my Intel notebook.
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

|nic|

  • Packager
  • Vectorite
  • ****
  • Posts: 162
    • My Blog
Re: Blank screen after suspend
« Reply #3 on: January 04, 2012, 02:01:21 pm »
@ Joe1962

Unfortunately it doesn't work, any other suggestions?
It's like when I'm trying to get out of suspend, the system freezes.

cheers
registered user #393337

Desktop AMD E6 / 8 gb ram / 120 GB SSD / 500 gb HD / VL7

Samsung NP110 / VL7.1 Std

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Blank screen after suspend
« Reply #4 on: January 04, 2012, 03:17:26 pm »
nicdm,

what kernel version are you running there?
is this on 32 or 64bit?

|nic|

  • Packager
  • Vectorite
  • ****
  • Posts: 162
    • My Blog
Re: Blank screen after suspend
« Reply #5 on: January 05, 2012, 12:03:36 am »
uelsk8s ,

I'm running VL7 standard Gold 32 bit with kernel 3.0.8
registered user #393337

Desktop AMD E6 / 8 gb ram / 120 GB SSD / 500 gb HD / VL7

Samsung NP110 / VL7.1 Std

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Blank screen after suspend
« Reply #6 on: January 05, 2012, 05:55:34 am »
there is a fix in the latest kernels for broken resume. can you try one of them and see if it works for you?
there is 3.0.15, and 3.1.7 in the repo

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: Blank screen after suspend
« Reply #7 on: January 05, 2012, 09:59:47 pm »
uelsk8s, could you be a little more specific about the new kernel resume fixes?  I looked in the regular and testing repositories under "kernel" and didn't see anything new.  Plus, the kernel symbol shows a locked symbol.

VL7.0 xfce4 Samsung RF511

Pita

  • Vectorian
  • ****
  • Posts: 1325
Re: Blank screen after suspend
« Reply #8 on: January 06, 2012, 12:04:15 am »
uelsk8s, could you be a little more specific about the new kernel resume fixes?  I looked in the regular and testing repositories under "kernel" and didn't see anything new.  Plus, the kernel symbol shows a locked symbol.



http://vectorlinux.osuosl.org/veclinux-7.0/kernels/

so I am not uelsk

|nic|

  • Packager
  • Vectorite
  • ****
  • Posts: 162
    • My Blog
Re: Blank screen after suspend
« Reply #9 on: January 06, 2012, 02:20:55 am »
Hi,

 I tried both Kernels, but the problem  is still the same.
Can It be related to Grub?
registered user #393337

Desktop AMD E6 / 8 gb ram / 120 GB SSD / 500 gb HD / VL7

Samsung NP110 / VL7.1 Std

WINDOWS_KILLER

  • Member
  • *
  • Posts: 8
Re: Blank screen after suspend
« Reply #10 on: March 01, 2013, 04:57:30 am »
i have the same problem :(

retired1af

  • Packager
  • Vectorian
  • ****
  • Posts: 1283
Re: Blank screen after suspend
« Reply #11 on: March 01, 2013, 05:34:06 am »
i have the same problem :(

You said you installed VL 6. So no. You do NOT have the same problem.
ASUS K73 Intel i3 Dual Core 2.3GHz

AndK

  • Member
  • *
  • Posts: 34
Re: Blank screen after suspend
« Reply #12 on: February 23, 2015, 09:36:38 am »
I have though.
Nothing seems to "wake up" my Thinkpad X30 with VL 7 Standard installed. The CPU fan is spinning like crazy.

Cheers