Please support VectorLinux!

Author Topic: kernel 3.2  (Read 3466 times)

vincent2

  • Vectorite
  • ***
  • Posts: 412
kernel 3.2
« on: January 09, 2012, 08:27:10 pm »
Bonjour!

Just tried kernel 3.2 from repo(http://vectorlinux.osuosl.org/veclinux-7.0/kernels/3.2-1vl70/) on my old sharp mebuis laptop,it works fine...
hope more vectorbies would try it and updated to it. better support to wifi chips,ext4, more improvement on powersaving.

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: kernel 3.2
« Reply #1 on: January 10, 2012, 07:37:57 am »
Running it on an HP ProBook 4510s. So far so good, but can't tell any performance difference yet. I have to do some real testing. Also, I had read about the Intel IOMMU boot problems so I compiled the kernel with the following options at first:

CONFIG_INTEL_IOMMU=y
# CONFIG_INTEL_IOMMU_DEFAULT_ON is not set

Will try with it activated by DEFAULT next.


EDIT: Intel IOMMU boot issue reference: http://www.phoronix.com/scan.php?page=news_item&px=MTAzNzk
« Last Edit: January 10, 2012, 07:41:23 am by Joe1962 »
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

vincent2

  • Vectorite
  • ***
  • Posts: 412
Re: kernel 3.2
« Reply #2 on: January 10, 2012, 07:22:40 pm »
Bonjour,

I didn't encounter that issue as the sharp mebuis laptop is driven by AMD xp-1500 cpu.

murali

  • Member
  • *
  • Posts: 14
Re: kernel 3.2
« Reply #3 on: January 24, 2012, 08:50:58 pm »
Installed the new kernel, machine boots up fine, however internet doesn't work, any idea what can be done to fix it?

thanks.

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: kernel 3.2
« Reply #4 on: January 24, 2012, 10:06:34 pm »
murali, did your VL get an IP? what is the hardware?

murali

  • Member
  • *
  • Posts: 14
Re: kernel 3.2
« Reply #5 on: January 25, 2012, 03:37:04 am »
With the default kernel that came with VL7.0, everything works fine. However i wanted to try out 3.2 on reading this thread so downloaded kernel-src-3.2-i686-1vl70.txz, kernel-modules-3.2-i686-1vl70.txz, and kernel-3.2-i686-1vl70.txz and installed them using installpkg in that order. I then booted using the new kernel when i observed the internet not working. I also tried with vasm to configure dhcp, it didn't give any error but also didn't start the net.

Machine specs - Thinkpad R61, 2G RAM, Intel 945GM chipset

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4076
Re: kernel 3.2
« Reply #6 on: January 25, 2012, 04:14:12 am »
With the new kernel running, did you run command "depmod -aq", then reboot?

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: kernel 3.2
« Reply #7 on: January 25, 2012, 04:36:42 am »
post the output of lsmod and lspci on kernel 3.2

murali

  • Member
  • *
  • Posts: 14
Re: kernel 3.2
« Reply #8 on: January 25, 2012, 07:25:05 pm »
Strangely it's working now  ???, not sure what happened earlier.

On a slightly different topic, i feel the machine to be little slow at times, i happened to choose jfs instead of ext4, could that be the cause?

Thanks for your help.

pierce.jason

  • Packager
  • Vectorite
  • ****
  • Posts: 250
Re: kernel 3.2
« Reply #9 on: February 09, 2012, 06:02:04 pm »
On a slightly different topic, i feel the machine to be little slow at times, i happened to choose jfs instead of ext4, could that be the cause?

I did a JFS installation on a new SATA SSD hard drive a while back. I was thoroughly disappointed with the speeds. They seemed about on par with my ancient ATA/133 20GB consumer drive. I don't know if this was directly related to JFS choice or not, but JFS certainly did not give me the benefits that I was expecting it to.

I think JFS would work well in a specific environment. As a fairly normal desktop user though, I did not present it that environment.
pierce.jason
Email: $(echo -e "moc\x2eliamg\x40nosaj.ecreip" | rev)

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: kernel 3.2
« Reply #10 on: February 10, 2012, 08:15:10 am »
An update: Works OK here with CONFIG_INTEL_IOMMU_DEFAULT_ON set. I am currently on kernel 3.2.4, downloading the 3.2.5 patch today, which is where the ASPM power regression issue is supposed to be finally fixed.
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10