VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: vlc-1.1.13  (Read 1385 times)

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4140
vlc-1.1.13
« on: January 10, 2012, 03:09:18 pm »

Our current vlc-1.1.2 will not play this file:
http://download.blender.org/peach/bigbuckbunny_movies/big_buck_bunny_480p_surround-fix.avi

I tried upgrading to 1.1.13 from connie's alien slackbuilds and it works great. We should have our own version of it.
http://connie.slackware.com/~alien/slackbuilds/vlc/build/
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: vlc-1.1.13
« Reply #1 on: January 12, 2012, 04:07:04 pm »

Built and uploaded to repo.
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4140
Re: vlc-1.1.13
« Reply #2 on: January 12, 2012, 07:04:57 pm »

Tested. I can see Big Buck Bunny now.  ;D

This package also shows dep avahi >= 0.6.30.
Works fine with the installed 0.6.28 though.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4140
Re: vlc-1.1.13
« Reply #3 on: January 13, 2012, 08:18:46 am »

Spoke too soon :(

Tried again on a fresh install of Light. Problem remains with the VL package.
I'm thinking that some codecs are missing, guess my initial system somehow retained them between upgrades.
Looking at alienbob's package; it's 21MB. Ours is only 7MB.
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: vlc-1.1.13
« Reply #4 on: January 13, 2012, 11:15:28 am »

OK, I'll run alien bob's package.
edit.
Alien Bob's package includes a new ffmpeg 0.9 and all of it's dependencies.
We tend to build ffmpeg as a separate package.

I'll still give it a test, if it is a totally static package it may work, but if it upgrades ffmpeg to 0.9 it will break a number of applications and they will also have to be rebuilt.
« Last Edit: January 13, 2012, 11:46:07 am by stretchedthin »
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4140
Re: vlc-1.1.13
« Reply #5 on: January 13, 2012, 03:13:04 pm »

For what it's worth, on my VL6 system, the file in question plays without problems using the VL packages for vlc-1.0.5 and mplayer.
On VL7, neither vlc nor mplayer handles it. Maybe there is some other way of providing the necessary codecs (FMP4 MPEG-4).

Whatever works.
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: vlc-1.1.13
« Reply #6 on: January 13, 2012, 09:33:08 pm »

@nightflier
Desided to test and I am playing http://download.blender.org/peach/bigbuckbunny_movies/big_buck_bunny_480p_surround-fix.avi in vlc 1.1.2 on a fresh install of VL7.0 32bit gold in Virtual Box, no problem.

Upgraded to 1.1.3 and tested it as well and that one had a missing video format mp4v. 
Which made me think the problem must rest with the new vlc 1.1.3 and not ffmpeg.

So I did another test and used ffmpegs own player on the link and it worked, not great but it worked.
Code: [Select]
ffplay http://download.blender.org/peach/bigbuckbunny_movies/big_buck_bunny_480p_surround-fix.avi

Mplayer also had no problem with this video. So I'm thinking it is not a codec problem.

So in the end I think I'll have to pull my build of vlc 1.1.13 and play with it a bit.  Don't know what has changed since I used the same SlackBuild as 1.1.12.  Hope to find out.

Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: vlc-1.1.13
« Reply #7 on: January 14, 2012, 11:02:21 pm »

ok, think I got it. vlc-1.1.13-i586-2vl70.txz uploaded and ready for testing.

Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4140
Re: vlc-1.1.13
« Reply #8 on: January 15, 2012, 08:17:02 am »

Tested on Std. Gold and works. I appreciate it.  :)

The problem I described must be one of my own doing. In Light, I replaced mplayer with vlc (personal preference because of the way it interacts with Firefox). I thought vlc was all self contained, but it seems like it must use codecs provided by other packages if it can't use it's own.
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: vlc-1.1.13
« Reply #9 on: January 15, 2012, 06:08:33 pm »

No problem. I think it helped the vlc 1.1.13 package in the end. 
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee