Please support VectorLinux!

Author Topic: Kernel headers  (Read 964 times)

pinnerite

  • Member
  • *
  • Posts: 36
Kernel headers
« on: January 17, 2012, 05:43:40 am »
When trying to install VirtualBox, I found the repository holds the headers for version 2.6.38.3 whereas the installed kernel is 3.0.8. How on earth can I proceed?

Nice distro by the way.

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --

Kimdino

  • Member
  • *
  • Posts: 16
Re: Kernel headers
« Reply #2 on: May 27, 2012, 02:23:31 pm »
Seeing no reply from the original poster as to the result I thought I'd post my experiences with this answer.
I had the same problex trying to install VirtualBox in VL6.0. Kernel version was 2.6.27.29, whereas GSlapt would only give me the headers for 2.6.24.5.

I tried hata_ph's solution, only using http://vectorlinux.osuosl.org/veclinux-6.0/kernels/kernel-src-2.6.27.29-i686-1vl60.tlz and it worked a treat.

Thanks, hata_ph