VectorLinux
October 22, 2014, 08:57:07 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Wireless via PCI Adapter [Solved]  (Read 1313 times)
pinnerite
Member
*
Posts: 36


« on: January 20, 2012, 02:15:19 pm »

I have just installed a PCI wireless adapter on a system running Vector Linux 7.0.
Running the same machine from a Parted Magic Live CD, it works perfectly but
under VL 7.0 it doesn't even appear to be detected. Am I missing a driver module?
« Last Edit: January 23, 2012, 01:50:04 pm by nightflier » Logged
hata_ph
Packager
Vectorian
****
Posts: 3258


-- Just being myself --


« Reply #1 on: January 20, 2012, 06:36:59 pm »

paste the output of lspci, lsmod
Logged
pinnerite
Member
*
Posts: 36


« Reply #2 on: January 21, 2012, 04:57:02 am »

Yesterday when I ran lspci there was no reference to the Ralink device. Same on lsmod. When I booted up today to run them in order to reply, there was. I did a search on Google for my own website and up it came. I cannot imagine why this should be. So sorry to have troubled you and thank you for taking the trouble.
Logged
pinnerite
Member
*
Posts: 36


« Reply #3 on: January 21, 2012, 05:22:15 am »

I spoke too soon. I had forgotten that last night I had plugged an Ethernet lead in to make contact and of course that was still in when I ran Parted Magic! (Idiot!).

So back to square one. Attached are listings from lspci and lsmod.

I have since booted up on PCLinuxOS liveCD and successfully logged into the wireless network, so the hardware is indeed fine. It must be down to the way I am setting up the connection. On the laptops I only seem to need the ESSID, selection of WAP and insertion of the shared key. I have done that here but it doesn't do the trick.

The Wicd Network Manager preferences has the Wireless interface as etho. Everyting else is set to defaults.


« Last Edit: January 21, 2012, 07:19:10 am by pinnerite » Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #4 on: January 21, 2012, 07:04:32 am »

Heh, been there, done that. It's how I learn. Wink

Your problem may be that wicd is not set to look at the correct interface. It defaults to "wlan0", but your device may be named "ra0". In a terminal, as root, issue command "iwconfig" and look for it. Then make sure that wicd preferences are correct.
Logged
pinnerite
Member
*
Posts: 36


« Reply #5 on: January 21, 2012, 10:29:46 am »

According to iwconfig, wlan0 comes up reporting IEEE 902.11bg, my ESSID and several other bits, one of which is 'Encryption key=off". As I had entered a WAP pass pass phrase, that looks decidedly odd.
Logged
hata_ph
Packager
Vectorian
****
Posts: 3258


-- Just being myself --


« Reply #6 on: January 21, 2012, 05:16:58 pm »

what is the output of iwconfig and ifconfig -a with your wireless plugin?
Logged
pinnerite
Member
*
Posts: 36


« Reply #7 on: January 21, 2012, 05:43:34 pm »

Using vasm I managed to get the system to recognise the wireless network but when I try to 'connect' I get 'Connection failed: Bad password'.

Frustrated, I decided to cheat (I know). I copied the network settings from the wpa_supplicant.conf file on my Asus PC901 netbook. I also made sure that the target computer's MAC number was included as an 'allowed' accessor on my wireless router.

After restarting both the router and the target machine, I still have the same problem.

Here are the contents of iwconfig and ifconfig -a

vector://home/victor
root:# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"asandco7" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated   
          Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
         
vector://home/victor
root:#

root:# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:20:ED:77:48:B4 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:549 errors:0 dropped:0 overruns:0 frame:0
          TX packets:549 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:44652 (43.6 Kb)  TX bytes:44652 (43.6 Kb)

wlan0     Link encap:Ethernet  HWaddr 00:A0:11:09:0B:51 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

vector://home/victor

Thanks in advance






Logged
hata_ph
Packager
Vectorian
****
Posts: 3258


-- Just being myself --


« Reply #8 on: January 22, 2012, 04:29:50 pm »

ok...from your ifconfig/iwconfig your wireless adapter is assigned as wlan0...check WICD to use wlan0 and try use WICD to connect to your network...
Logged
pinnerite
Member
*
Posts: 36


« Reply #9 on: January 23, 2012, 04:19:45 am »

As far as I could see, one cannot set the interface in WICD, only in vasm where it was already set to wlan0. Can I assume that the WPA_supplicant is correct?

Anyway, Wicd is reporting my network name, -42dBm, WPA and Channel 11. It just will not connect. The problem seems to me to be a mis-match in protocols

My adapter uses a Ralink RT2561/RT61 device, so I used -Dralink in my wpa_supplicant command.

Properties are defaults except for 'Use Encryption' which is ON, WPA 1/2 (Prshared Key) and the key itself.


Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #10 on: January 23, 2012, 05:01:36 am »

Left-click the wicd systray icon, maximize the resulting window and look for the Preferences icon right below the title bar.
Logged
pinnerite
Member
*
Posts: 36


« Reply #11 on: January 23, 2012, 05:52:54 am »

I am using VL 7.0. The screen has an icon ribbon at the bottom and a menu bar at the top. There is no WiCD icon in the ribbon at the foot and right-clicking on the icon at the top offers: connect, connect info and quit!
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #12 on: January 23, 2012, 06:03:00 am »

Wherever you right-clicked, do a left-click instead.

Or, Menu > Internet > Wicd Network Manager

If the wicd window is not big enough to show the Preferences button, look for a little down arrow in the upper right quadrant.
Logged
pinnerite
Member
*
Posts: 36


« Reply #13 on: January 23, 2012, 08:01:57 am »

Sorry, unfamiiarity with VL. The down arrow did it. I changed the interface to 'wext' and lo and behold, it worked like magic. Thank you for your patience. I almost gave up. I'll now put VL on my netbook as well. Thanks again,  Alan
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #14 on: January 23, 2012, 01:49:48 pm »

Cool! I'm marking this as solved.  Smiley
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!