VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Skype problem  (Read 2411 times)

Herpy

  • Vectorite
  • ***
  • Posts: 142
Skype problem
« on: January 26, 2012, 01:42:32 pm »

Everytime I am in a call, and when someone links me a video, when the video plays I lose the sound of the skype call. So I have to rejoin to get sound back, what is happening?
Logged
Forever in a box

Herpy

  • Vectorite
  • ***
  • Posts: 142
Re: Skype problem
« Reply #1 on: January 26, 2012, 08:53:55 pm »

I think I fixed the problem, I turned indipendent off useing the alsamixer through the terminal.
Logged
Forever in a box

Herpy

  • Vectorite
  • ***
  • Posts: 142
Re: Skype problem
« Reply #2 on: January 26, 2012, 09:04:15 pm »

This is what it should look like    http://herpy1.deviantart.com/art/thingy-281726877
Logged
Forever in a box

Herpy

  • Vectorite
  • ***
  • Posts: 142
Re: Skype problem
« Reply #3 on: February 04, 2012, 11:04:31 am »

It's doing it again.
Logged
Forever in a box

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2305
Re: Skype problem
« Reply #4 on: February 04, 2012, 04:09:40 pm »

Hi Herpy,

AFAIK you cant use the soundcard from more than one software instance directly through alsa. You would need an extra layer like pulseaudio, or another kind of sound server which would manage the resources for the applications.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

Herpy

  • Vectorite
  • ***
  • Posts: 142
Re: Skype problem
« Reply #5 on: February 04, 2012, 04:24:25 pm »

Hi Herpy,

AFAIK you cant use the soundcard from more than one software instance directly through alsa. You would need an extra layer like pulseaudio, or another kind of sound server which would manage the resources for the applications.
It was working fine before.  How do I get pulseaudio set up?
Logged
Forever in a box

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: Skype problem
« Reply #6 on: February 04, 2012, 06:04:44 pm »

Herpy, maybe there is a relation between your skype problems and the use of Vdefsound.  Vdefsound sets up a new asoundrc in user space, perhaps skype does not like that.  Try unplugging your webcam and boot up again so that Vdefsound is not deployed on the system and see if it makes any difference.
Ken
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

Herpy

  • Vectorite
  • ***
  • Posts: 142
Re: Skype problem
« Reply #7 on: February 05, 2012, 12:01:27 pm »

Herpy, maybe there is a relation between your skype problems and the use of Vdefsound.  Vdefsound sets up a new asoundrc in user space, perhaps skype does not like that.  Try unplugging your webcam and boot up again so that Vdefsound is not deployed on the system and see if it makes any difference.
Ken
Nope, skype just hates linux for some reason.

Herpy
Logged
Forever in a box

sledgehammer

  • Vectorian
  • ****
  • Posts: 1463
Re: Skype problem
« Reply #8 on: February 05, 2012, 07:11:02 pm »

Herpy,

Have you given twinkle, linphone, jitsi or google voice/talk a try.  Though I found skype easy to use on slackware-linux, Google Voice/Talk is better, in my book, for many reasons.
Logged
VL7.0 xfce4 Samsung RF511

Herpy

  • Vectorite
  • ***
  • Posts: 142
Re: Skype problem
« Reply #9 on: February 06, 2012, 11:58:05 am »

I undid the vDefsound and alsa detected my usb mic as default yet again, so I used the terminal and used the nano /ect/modprobe.d/sound method and now everything is dandy, I can hear the skype sounds and I can also hear the sound of videos (Hence that my skype friends always send me vids to react to) so I think that that's a bug that you need to squash in vDefsound Ken

Herpy
Logged
Forever in a box

yonpa

  • Member
  • *
  • Posts: 1
Re: Skype problem
« Reply #10 on: February 18, 2012, 01:33:08 pm »

Your can't here any voice, may be check your setting on your Skype. First close your Skype application. also in the taskbar. Then open again to refresh the Skype application, then log in to your account, Click  the tools on the menu bar then click options. Try to configure or test your setting, click audio setting then click play on the speakers to test the audio of your computer. Also check the MIC for good call conversation. If you can't hear anything, try to check your setting to your volume control. Check after checking and its not working check your drivers. If your sound card has correctly working. Hope it can help. And you may also check this site for more informations regarding your problem It has a many options you can get there,,>>
http://www.techyv.com/questions/do-not-hear-sound-skype
Logged