VectorLinux
April 24, 2014, 12:18:11 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Killing Thunar (Solved)  (Read 931 times)
sledgehammer
Vectorian
****
Posts: 1397



« on: January 30, 2012, 09:38:23 pm »

Does anyone know why thunar keeps coming back?  Like, do I have a ghost in my laptop?  I kill it.  Put a stake through its heart.  Double check gslapt.  Its not installed.  But Thunar still lurks somewhere in the innards of my computer.  Only reason I don't like it is that the "open terminal here" button doesn't work. Pcmanfm's does.  So I only need pcmanfm.  But no.  Do I get pcmanfm?  No!  I get thunar.  When I need to open a terminal in that directory, I have to open pcmanfm, go back to the directory and then open the terminal.  

Practically, this problem comes up when using Note Taking Simplified (nts), Dan Graham's wonderful python based note taking program.  The user can either use a master note, with different subjects, or, as I do, put separate nts files in each directory in question.  So I go to the directory in question, try to open a terminal and then realize I am in thunar. A program I have killed.  Then have to open pcmanfm, navigate to the directory, and then open a terminal which lets me open the notes file.
« Last Edit: February 01, 2012, 08:04:50 pm by sledgehammer » Logged

VL7.0 xfce4 Samsung RF511
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: January 30, 2012, 11:33:50 pm »

Can't say for sure why Thunar keeps returning if you have uninstalled it, but may be able to help in a couple other issues.

If you want pcmanfm as your default, go to Menu->Settings->Preferred Applications and switch from the internet tap to the utility tab.
Under File Manager change the selection from Thunar to pcmanfm.  Your note taking program may be opening it if it thinks it is the system preferred.

Right Click on the Thunar icon on the panel and select properites. In the resulting window click the pencil icon on the bottom right. Change the command from thunar to pcmanfm.

On the other hand you shouldn't be having trouble opening a terminal with Thunar.

Which terminal are you using with pcmanfm "xterm", "Terminal" or other?
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
sledgehammer
Vectorian
****
Posts: 1397



« Reply #2 on: January 31, 2012, 11:46:05 am »

Hi Stretchthin,

Thanks for the response.  However, I did the stuff you suggest weeks, probably months ago.  I just looked again and pcmanfm is the preferred file manager and, though there is no Thunar icon in the panel, the icon for the file manager has pcmanfm as the command.

As to the terminal I am using, it is, I believe, the VL7 default terminal. Terminal 0.4.8.  This (Terminal 0.4.8 ) is also the terminal that pcmanfm opens when I push F4 in pcmanfm.

And, while I'm at it, thanks for all your wonderful Vector videos.  

John
« Last Edit: January 31, 2012, 11:49:48 am by sledgehammer » Logged

VL7.0 xfce4 Samsung RF511
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #3 on: January 31, 2012, 12:28:15 pm »

Well the executable for (Terminal 0.4.8 ) is just terminal or Terminal at the command line.
Give it a test and move on to the next step is a new terminal opens with either of those commands.

In the thunar filemanager try this...
Go to "Edit" --> "Configure Custom Actions"
Highlight "Open Terminal Here" and click on the edit pencil icon to the left.
Make sure the Command line reads...
Terminal --working-directory %f

Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
sledgehammer
Vectorian
****
Posts: 1397



« Reply #4 on: January 31, 2012, 04:58:32 pm »

Well,

I see I started this thread in the wrong topic, but thanks again for your suggestion.  I have put "Terminal --working-directory %f" into the Thunar program and will know soon whether that works.  I will let the forum know.

John
Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1397



« Reply #5 on: February 01, 2012, 09:38:43 am »

I will make one more comment here and then, this weekend, move this request to a proper topic, probably Technical Requests. 

I have tried all suggestions and add the following:

It (default to Thunar file manager) happens on reboot.  The first screen shown after login is the Thunar file directory.  So I must be telling it to use Thunar in some program read on reboot.

John
Logged

VL7.0 xfce4 Samsung RF511
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #6 on: February 01, 2012, 01:28:00 pm »

sledgehammer
Check menu-->settings-->Session and Startup
and see if there is anything for thunar in applications autostart tab.

Also check /etc/xdg/autostart        for any desktop files that would start thunar.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
sledgehammer
Vectorian
****
Posts: 1397



« Reply #7 on: February 01, 2012, 08:04:00 pm »

Stretchedthin,

Quote
Check menu-->settings-->Session and Startup
and see if there is anything for thunar in applications autostart tab.

Excellent suggestions.  "file manager" was checked to autostart. When I edited "file manager" it said "command:  Thunar."

I changed it to "command:  pcmanfm" and strongly suspect that will fix my problem.  Still something of a mystery why Thunar would run at all.  I checked gslapt just now and there is no thunar listed.  Just thunar-volman and ucastall.  Don't see a "thunar" per se.  I have testing repository enabled. 

Anyway, thanks for the suggestions.  They worked.

Logged

VL7.0 xfce4 Samsung RF511
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!