VectorLinux
October 25, 2014, 02:57:41 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: gnucash-docs install Vector 7  (Read 4069 times)
sledgehammer
Vectorian
****
Posts: 1425



« on: February 05, 2012, 01:13:01 am »

 installed gnucash tonight.  Haven't used it before.  After install, with testing repository enabled, it just flashed briefly and then shut down.  I tried to install webkit (which something said gnucash might need) from the repository but it said "dependency error", so I installed an earlier version of webkit from slackbuilds.  Still got just a brief flash.  Reinstalled gnucash 2.4.9 from the repository, reinstalled slib and it worked.   Apparently the order of dependency installs is important.

BUT, though gnucash is apparently working well, the doc files (help and guide) are not installed.  I downloaded them as PDFs but would like to integrate them into the gnucash program.   Any thoughts here?
Logged

VL7.0 xfce4 Samsung RF511
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: February 05, 2012, 07:26:41 am »

Good tips Sledgehammer;

I'll see if I can tidy gnu-cash up when I get some time off on Tuesday.
(Think I still owe someone else a promise on getting compiz into 64bit as well, so I'll get to it right after that.)
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
sledgehammer
Vectorian
****
Posts: 1425



« Reply #2 on: February 05, 2012, 08:45:24 am »

No hurry needed from my standpoint.   I don't know enough about gnucash yet to know if the doc files are better integrated or as stand-alone pdfs.

Your slackware videos are becoming quite popular.   I am developing the habit of looking for them when I have questions. When I ran into install trouble with gnucash, I looked for one (on opensourcebistro.com).  Of course, it wasn't there.  Point is I looked. 
Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1425



« Reply #3 on: February 06, 2012, 10:46:59 pm »

I have a big mouth.  I was telling everyone at the office today about gnucash, how impressed I am, how I wished I had loaded it years ago, etc.  To my surprise, one of the tenants in our building, a recent Stanford Law school graduate, matter-of-factly told me he had been using it for years and that gnucash satisfied all his accounting needs.  Small world.
Logged

VL7.0 xfce4 Samsung RF511
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #4 on: February 07, 2012, 03:53:33 am »

That's encouraging to hear. Maybe there are more "silent" users of FOSS out there than we realize.
Logged
milo28
Member
*
Posts: 7



« Reply #5 on: February 11, 2012, 12:56:13 pm »

I just installed GnuCash yesterday, and I had the same problem of aborted application startup. I tried to start it from the terminal, and noticed that the errors had to do with permissions problems. I tried running it as root, which worked beautifully. Of course, I didn't want to do my accounting as the super user, so I was happy to find the tip from sledgehammer above. I just reinstalled slib and now my regular user login can run GnuCash! No need to install webkit.

(Of course, I had to chown my GnuCash file back over to my regular user account.)

I am also what you might call a "silent" FOSS user. I don't work in the tech industry - I'm a neurology resident. I started using the GIMP back in undergrad, then discovered Mozilla, OpenOffice, and other Free/Open apps. I even read the GNU manifesto. Eventually I started playing with Linux, and actually VectorLinux was the first distro I installed and kept. Interestingly, my killer app for Linux was GnuCash, because there wasn't a Windows version back then. I've been doing all of my accounting with it since early 2004. I migrated my wife over to Linux about 5 years ago, and she is happy with it too.
Logged
sledgehammer
Vectorian
****
Posts: 1425



« Reply #6 on: September 05, 2012, 11:23:10 am »

I just installed gnucash on another machine, running VL 7 standard.  It installed fine but the help button does not work.  Says it cannot find the files.  gslapt shows that the gnucash-docs are installed but I don't know where to find them.

Any thoughts here?

John
Logged

VL7.0 xfce4 Samsung RF511
hata_ph
Packager
Vectorian
****
Posts: 3258


-- Just being myself --


« Reply #7 on: September 05, 2012, 05:08:00 pm »

sledgehammer,

What version of gnucash you having?
Do you have /usr/share/gnucash/doc/ in your system?
Logged
sledgehammer
Vectorian
****
Posts: 1425



« Reply #8 on: September 05, 2012, 08:27:24 pm »

Quote
What version of gnucash you having?

2.4.9-i586-1vl70

Quote
Do you have /usr/share/gnucash/doc/ in your system?

Yes.  It has an INSTALL file but I did not use that as gnucash is already installed.

John
Logged

VL7.0 xfce4 Samsung RF511
hata_ph
Packager
Vectorian
****
Posts: 3258


-- Just being myself --


« Reply #9 on: September 05, 2012, 10:11:11 pm »

sledgehammer,

try this http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/gnucash-docs-2.4.1-i586-1vl70.txz

PS: I cannot find the gnucash-docs for version 2.4.9
Logged
sledgehammer
Vectorian
****
Posts: 1425



« Reply #10 on: September 05, 2012, 10:39:55 pm »

Thanks hata_ph

I tried your docs suggestion and it did not work.   

I looked around a bit, too, and found http://www.linuxfromscratch.org/blfs/view/svn/xsoft/gnucash.html

That site references gnucash 2.4.10 and has some downloads, including a required patch.  However, they are not in slackware format so I have not tried them.  Nonetheless it still uses gnucash-docs-2.4.1, so I suspect the problem lies in the "required" patch referenced on that site.

John
Logged

VL7.0 xfce4 Samsung RF511
hata_ph
Packager
Vectorian
****
Posts: 3258


-- Just being myself --


« Reply #11 on: September 06, 2012, 11:28:11 pm »

Ok...it seem gnucash-docs will only work when yelp install...I build yelp-2.30.1 but gnucash still cannot open the documentation page...newer yelp need gtk+3 which is a not possible in VL7. So I have no idea now... Sad
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!