VectorLinux
October 30, 2014, 08:22:23 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: modprobe.d/sound problem[Solved]  (Read 1455 times)
Herpy
Vectorite
***
Posts: 141



« on: February 14, 2012, 12:14:36 pm »

Hello, I made a recent thread about the soundcard default thingy, well I tried the nano ect/modprobe.d/sound option but when I save it, it so called saved it to a file and when I hit enter I get this message

so I tried vDefsound to change it and well, I can only play one sound at a time, like when I am watching a movie and pause it to get in a skype call then I can't hear skype. What the hell is happening? Need help pronto!
« Last Edit: February 14, 2012, 01:40:43 pm by Herpy » Logged

Forever in a box
Herpy
Vectorite
***
Posts: 141



« Reply #1 on: February 14, 2012, 12:36:55 pm »

Got rid of asoundrc and that seemed to fix the problem, but the modprobe.d only seemes to last one reboot before it goes back to choosing my usb desktop mic as default again, fix please?
Logged

Forever in a box
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #2 on: February 14, 2012, 12:51:31 pm »

herpy
In the pic you posted you wre trying to write to "/ect/"  and not "etc" and that's why you were getting the directory error.

I think the problem with .asoundrc is that it is in userspace, I will do some testing here to see if the same thing works better in systemspace.

Let me know if the howto you are following here
Works out for you.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
Joncho
Member
*
Posts: 45


« Reply #3 on: February 14, 2012, 01:12:02 pm »

I had the same problem, I have a PCI soundcard but Vector would set the mic of my usb webcam or (when the webcam was unplugged) my onboard sound chip as default sound device, i don't know if this will work for you but worked well for me:

I edited the /etc/modprobe.d/alsa.conf file (i don't remember well right now but i think the file didn't exist so if you don't find the file, just create it)
and added the following line (by the way it is the only line in my file):
Code:
options snd slots=snd-emu10k1

my soundcard is a Creative SB Audigy 2, so you replace the emu10k1 part with the name of the driver of your sound card:

basically you can set the order of preference for your sound devices like this

options snd slots=snd-device0,snd-device1,snd-device2...snd-deviceN

but it is no necessary, you don't need to write down all of your devices, just the one you want as default.
« Last Edit: February 14, 2012, 01:25:09 pm by Joncho » Logged
Herpy
Vectorite
***
Posts: 141



« Reply #4 on: February 14, 2012, 01:40:18 pm »

herpy
In the pic you posted you wre trying to write to "/ect/"  and not "etc" and that's why you were getting the directory error.

I think the problem with .asoundrc is that it is in userspace, I will do some testing here to see if the same thing works better in systemspace.

Let me know if the howto you are following here
Works out for you.
*double tactical facepalm* Ouch. No wonder why it would not work! I tried it and yes it worked perfectly, Marking this as solved for the time being.
Logged

Forever in a box
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #5 on: February 14, 2012, 01:47:38 pm »

Quote
*double tactical facepalm*

Classic!! Permission to plagiarise?
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
Herpy
Vectorite
***
Posts: 141



« Reply #6 on: February 14, 2012, 01:49:17 pm »

Quote
*double tactical facepalm*

Classic!! Permission to plagiarise?
permission granted!
Logged

Forever in a box
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!