VectorLinux
April 17, 2014, 12:12:00 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: something's wrong with video display (SOLVED, sort of)  (Read 2430 times)
sledgehammer
Vectorian
****
Posts: 1397



« on: February 07, 2012, 11:44:51 pm »

I can't think of anything I did to cause it, except perhaps to check 'save this session' on shutdown.  But now my screen is all screwed up.  I can't seem to stop the "save sessions."  I no longer have "save this session" checked, but when I reboot, everything seems normal, the panel shows and all that, but my programs keep loading and they overwrite the panel.  Plus the little icon at the upper right of most programs which allows one to close by clicking is not there.  And alt-tab does not work.  Only way to do anything is to close the open windows and finally get back to the default screen, where the panel dutifully shows.  Also, I normally run 7 or so workspaces and now only get one.  Settings workspaces says I have 4 or 7 or whatever workspaces (I can change it), but panel still only shows one workspace, i.e. my changes are ignored.  

Something is obviously bad wrong.  All my programs seem to work fine but the window does not work at all as is has in the past.   I rebooted into the tui and ran xwindow setup in vasm but that didn't help.  Also ran autosetup and that too didn't help.  

The windows manager icon in settings manager won't open.

I don't recall having had this problem before.  Any suggestions?

John
« Last Edit: February 08, 2012, 11:49:39 pm by sledgehammer » Logged

VL7.0 xfce4 Samsung RF511
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: February 08, 2012, 07:41:31 am »

Sledgehammer, I'm guessing you have installed compiz-meta package.

You can verify this if you can find "Compiz Settings Manager" under "Settings" in the menu.

Also you should have a new red black icon on the panel which if you right click it and choose "Select Window Manager"
Xfwm4.  Should take you back to normal.

Otherwise check out the following for some more help with compiz.
http://www.opensourcebistro.com/blog1/?p=581
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
sledgehammer
Vectorian
****
Posts: 1397



« Reply #2 on: February 08, 2012, 08:23:22 am »

I will look at the url now.  In the interim, I note that I must have the compiz window manager, though it just says "window manager."  I see no red button.  When, in terminal, I enter "xfwm4-settings," I get error message to the effect that that program won't work with my current windows manager.  Whatever program I try works, but is always on top and can't be minimized.

John
Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1397



« Reply #3 on: February 08, 2012, 09:41:45 am »

I looked at the url but decided not to try it for now, at least until I figure out why xfwm4-sessions doesn't work.  I deleted xfce from my home file .config/xfce4 and rebooted but that didn't help......it continued to load all the programs I was using when I clicked on "save this session: when shutting the computer down.  I think I need to find out what is telling it to do that (reload the last session).

I am now going to gslapt and will look for compiz and see what I see.

John
Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1397



« Reply #4 on: February 08, 2012, 10:41:21 am »

Reloading compiz didn't help.  I am at work now and the computer is usable, so I will have to look at this later, probably tonight.  Any suggestions in the interim are most appreciated.  I suspect that solution is in my figuring out how to get back to whatever windows manager I was using when I clicked on "save session"  when shutting down.  But then, I am wary here as I don't want to be "fixing" things which are not broken.  I do that far too often.

John
Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1397



« Reply #5 on: February 08, 2012, 08:41:43 pm »

Of necessity I am continuing to work on this.  Here is my session errors file in case it gives anyone any ideas:


/etc/gdm/Xsession: Beginning session setup...
You are working as johwhi
Frequently used programs:
Configuration  : vasm
File manager   : mc (press F2 for useful menu)
Editor         : mcedit, nano, vi
Multimedia     : alsamixer, play
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- startxfce4
/usr/bin/startxfce4: X server already running on display :0
xfdesktop[3317]: starting up

(xfce4-settings-helper:3343): xfce4-settings-helper-WARNING **: Failed to get the _NET_NUMBER_OF_DESKTOPS property.
xfce4-panel: No window manager registered on screen 0. To start the panel without this check, run with --disable-wm-check.
xfce4-settings-helper: Another instance is already running. Leaving...
GNOME_KEYRING_CONTROL=I ERASED THIS
GNOME_KEYRING_PID=I ERASED THIS

(xfce4-session:3295): Wnck-CRITICAL **: wnck_workspace_activate: assertion `WNCK_IS_WORKSPACE (space)' failed
GNOME_KEYRING_CONTROL=I ERASED THIS
SSH_AUTH_SOCK=I ERASED THIS
GNOME_KEYRING_CONTROL=I ERASED THIS

(gdu-notification-daemon:3426): libgdu-WARNING **: unhandled property 'DeviceAutomountHint'

(gdu-notification-daemon:3426): libgdu-WARNING **: unhandled property 'DeviceAutomountHint'

(gdu-notification-daemon:3426): libgdu-WARNING **: unhandled property 'DeviceAutomountHint'

(gdu-notification-daemon:3426): libgdu-WARNING **: unhandled property 'DeviceAutomountHint'

(gdu-notification-daemon:3426): libgdu-WARNING **: unhandled property 'DeviceAutomountHint'
Recap: recap.js loaded
Recap: createInstance called
Recap: startup observed
E: main.c: Daemon startup failed.
Warning: unrecognized command line flag -sm-config-prefix
Warning: unrecognized command line flag -sm-client-id
** (pcmanfm:3411): DEBUG: launch command: </usr/bin/opera 'file:///home/johwhi/.xsession-errors' >
** (pcmanfm:3411): DEBUG: sn_id = pcmanfm-3411-vector.Linux.net-/usr/bin/opera-0_TIME140300
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
Recap: quit observed
Recap: shutdown observed
Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1397



« Reply #6 on: February 08, 2012, 11:49:02 pm »

Well, though I didn't want to do this, I apparently solved the instant problem by going to VASM and resetting the defaults (reset default settings). I no doubt will discover that this requires me to "reset" some of my own "defaults," but I note that Thunar now seems to work properly ("show terminal here" now works).  No doubt, in a day or two, I will be back to where I was and perhaps better off for the effort.  At least I learned, however unwillingly, something about xfce.

John
« Last Edit: February 08, 2012, 11:51:10 pm by sledgehammer » Logged

VL7.0 xfce4 Samsung RF511
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!