Please support VectorLinux!

Author Topic: Compatability help please.  (Read 963 times)

Locator

  • Vectorian
  • ****
  • Posts: 756
Compatability help please.
« on: February 21, 2012, 10:58:13 am »
Can anyone out there please tell me what the other available version(s) of Linux are that Vector Linux 7.0 is compatible with, because sometimes when I go to download software, the websites in question often display a list of different Linux versions, and the lists rarely include the one I am using, which is Vector Linux 7.0?

bigpaws

  • Vectorian
  • ****
  • Posts: 1868
Re: Compatability help please.
« Reply #1 on: February 21, 2012, 11:54:29 am »
Usually Slackware.

Bigpaws

Locator

  • Vectorian
  • ****
  • Posts: 756
Re: Compatability help please.
« Reply #2 on: February 21, 2012, 12:31:13 pm »
Thanks, but what do you mean by "usually", and suppose that "Slackware" isn't listed as an option - What then?

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: Compatability help please.
« Reply #3 on: February 21, 2012, 01:52:39 pm »
If they have a 'generic' package (which is normally a .tar.gz or .tar.bz2 or something along those lines) it is always best to get that package and build from source.  If you cannot do this by yourself, feel free to post a package request for the software you are trying to get and it should be built for you shortly.

Joncho

  • Member
  • *
  • Posts: 45
Re: Compatability help please.
« Reply #4 on: February 21, 2012, 02:17:34 pm »
If there is no slackware package your options are:

  1. Build it from source.
  2. Request a package at this forum.
  3. Look for a Slackbuild to build your own package at slackbuilds.org (this could be really easy and convenient sometimes)

Locator

  • Vectorian
  • ****
  • Posts: 756
Re: Compatability help please.
« Reply #5 on: February 21, 2012, 06:31:32 pm »
I am beginning to think that it would be a lot easier if the Linux operating systems were all standardized.

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: Compatability help please.
« Reply #6 on: February 21, 2012, 07:13:56 pm »
I am beginning to think that it would be a lot easier if the Linux operating systems were all standardized.
Dont hold your breath on that one. 

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: Compatability help please.
« Reply #7 on: February 21, 2012, 08:20:22 pm »
Sometimes you can use the deb2targz or rpm2targz tools to convert a debian/ubuntu or fedora/CentOS package. There's also the "alien" program that helps you directly install .deb and .rpm packages.
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM