VectorLinux
September 01, 2014, 05:31:40 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [SOLVED] Choppy playing of mp4 files.  (Read 3337 times)
Pita
Vectorian
****
Posts: 1310


« on: February 27, 2012, 05:28:33 pm »

Videos taken with a Nokia N8 cellphone in mp4 format play very choppy when transferred
to our computers, one a PC desktop with 750 MB RAM and the other a
HP-2133 Netbook with 1 GB RAM.

The movements are very slow and sound does not match and after a while
sound stops altogether. CPU load is near 100 %. It does not matter which
player program is used.

How could that be improved?
« Last Edit: March 13, 2012, 06:26:41 pm by Pita » Logged
nightflier
Administrator
Vectorian
*****
Posts: 4022



« Reply #1 on: February 27, 2012, 06:06:18 pm »

The video driver is important when it comes to maximizing performance. I think your HP has the VIA Chrome chipset. You may have to specify the driver in xorg.conf. Do you know what video card is in your desktop?
Logged
Pita
Vectorian
****
Posts: 1310


« Reply #2 on: February 27, 2012, 10:46:49 pm »

The video driver is important when it comes to maximizing performance. I think your HP has the VIA Chrome chipset. You may have to specify the driver in xorg.conf. Do you know what video card is in your desktop?

That's a good question.  I don't.

Code:
$ /sbin/lspci
00:00.0 Host bridge: ALi Corporation Device 1683
00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller
00:02.0 PCI bridge: ALi Corporation M5249 HTT to PCI Bridge
00:03.0 ISA bridge: ALi Corporation M1563 HyperTransport South Bridge (rev 20)
00:03.1 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:04.0 Multimedia audio controller: ALi Corporation M5455 PCI AC-Link Controller Audio Device (rev 03)
00:0e.0 IDE interface: ALi Corporation M5229 IDE (rev c5)
00:0e.1 Ethernet controller: ALi Corporation M5261 Ethernet Controller (rev 30)
00:0f.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:0f.1 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:0f.2 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:0f.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

Code:
$ /sbin/lsmod |grep video
video                   9731  1 nouveau
uvcvideo               48380  0
videodev               55338  1 uvcvideo
i2c_core               13898  8 nouveau,drm_kms_helper,drm,i2c_algo_bit,videodev,i2c_ali15x3,i2c_ali1563,i2c_ali1535
thermal_sys             9985  2 video,processor

Does this tell anything and if so what would be entered as driver?
Now it says "nouveau" in xorg.conf, under section "Device".
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4022



« Reply #3 on: February 28, 2012, 05:01:41 am »

Output shows an nVidia NV34 [GeForce FX 5200] card. I used one of these with VL6 and the proprietary drivers, with good result. Download the binary blob from nvidia (looks like version 173.1431). You will also need to disable nouveau. The driver installation may do this for you, not sure about that.
Logged
Pita
Vectorian
****
Posts: 1310


« Reply #4 on: February 29, 2012, 08:02:02 pm »

Output shows an nVidia NV34 [GeForce FX 5200] card. I used one of these with VL6 and the proprietary drivers, with good result. Download the binary blob from nvidia (looks like version 173.1431). You will also need to disable nouveau. The driver installation may do this for you, not sure about that.

Thanks! Installed this version of nvidia on my PC desktop.

xine says:
Code:
Too many video packets in the buffer: (560 in 33607025 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

mplayer says:
Code:

*** Your system is too SLOW to play this!  ****
           ************************************************

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver
  - Try -ao sdl or use the OSS emulation of ALSA.
  - Experiment with different values for -autosync, 30 is a good start.
- Slow video output
  - Try a different -vo driver (-vo help for a list) or try -framedrop!
etc

May it should read your machine is too old. Wink

Will try nvidia on the HP-2133 later.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4022



« Reply #5 on: March 01, 2012, 04:04:09 am »

Yea, decoding mp4 video requires some muscle. For your HP-2133, check to see what video card it has (lspci | grep VGA) before trying to install any proprietary drivers.
Logged
Pita
Vectorian
****
Posts: 1310


« Reply #6 on: March 01, 2012, 07:24:24 pm »

It seems mp4 format is not always the same. The same length in time clip
is different in size from another one. And large clips over 40000K size will
not play. Smaller than that plays well.
Logged
Pita
Vectorian
****
Posts: 1310


« Reply #7 on: March 11, 2012, 06:50:26 pm »

Found now easy solution:

convert mp4 format to mpg format using program ffmpeg. Cheesy
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!