VectorLinux
July 22, 2014, 05:26:38 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [solved] Thunderbird localization (either en-CA or en-GB)  (Read 1192 times)
MarkGrieveson
Vectorian
****
Posts: 531


« on: March 12, 2012, 12:29:27 pm »

I installed the thunderbird-langpack-en-GB version 3.1.7-i586-1vl70, which pulled in Thunderbird version 10.0-i586-1vl70.  However, the spelling was still US-english (IE, "favorite folder", or the date format of mm/dd/yy), and I couldn't find a way to change this.  So I tried installing Thunderbird version 3.1.7-i586-1vl70 first, and then the langpack, but it still came out as US-english.  I've subsequently upgraded again to version 10.0-i586-1vl70, and have not yet found a solution to changing the locale setting of Thunderbird.  I have edited /etc/profile.d/lang.sh replacing en-US with en-CA, which did change the language settings of some programs (IE, Abiword), but that did not affect Thunderbird.

Note, I’m not talking about the spell check.  I did get an extension for that -- Canadian dictionary -- which works.  Rather I’m talking about the spelling that’s on Thunderbird itself.  So, does anyone know how to get the package thunderbird-langpack-en-GB recognized by Thunderbird?  
« Last Edit: April 23, 2012, 06:35:10 am by MarkGrieveson » Logged

I am using VL7.0 standard with XFCE
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #1 on: March 31, 2012, 03:23:29 pm »

I did manage to fix this.  Since Vector Linux upgraded to Thunderbird version 11, I was able to get the en-GB language pack from here, which I installed similar to installing add-ons.  I then opened the config editor in Thunderbird (Preferences -> Advanced -> General), and searched for the entry general.useragent.locale and set its value to en-GB.  After restarting, the changes took place.

Since the developers have updated the thunderbird package, it might be a good idea to update the various language packs too.  Currently language packs are all version 3.1.7, rather than version 11 (so they don't work with version 11).
Logged

I am using VL7.0 standard with XFCE
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #2 on: April 01, 2012, 05:47:47 pm »

The thunderbird language pack is freely be download from mozilla website so I don't think we need to maintain a package in the VL repo.

http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/latest/linux-i686/xpi/
http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/latest/linux-x86_64/xpi/
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!