Please support VectorLinux!

Author Topic: [solved] issues with last upgrade after install of VL-7.0  (Read 1240 times)

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
[solved] issues with last upgrade after install of VL-7.0
« on: March 12, 2012, 12:54:27 pm »
Hello.  After installing VL-7.0, I did an upgrade with gslapt-get using only the default sources (VL-7.0 packages, extra, and patches), and encountered the following issues:

  • gegl and gimp could not upgrade:
Code: [Select]
Packages with unmet dependencies:
gegl: Depends: ffmpeg >= 0.10
Packages excluded:
gegl 0.1.8-i586-1vl70
gimp 2.7.3-i586-1vl70

  • inkscape was broken:
Code: [Select]
mark:$ inkscape
inkscape: error while loading shared libraries: libMagick++.so.4: cannot open shared object file: No such file or directory
vector:/~
mark:$

Fixed inkscape with the following:
Code: [Select]
root:# ln -s /usr/lib/libMagickWand.so.5 /usr/lib/libMagickWand.so.4
    Thanks Joncho for your help!

    • thunderbird-langpack-en-GB  version 3.1.7-i586-1vl70 failed to make a difference to the en-US setting of Thunderbird (either 3.1.7-i586-1vl70 or 10.0-i586-1vl70)

    So, I hope this information can help the developers of this great distribution to make it even better.
« Last Edit: April 23, 2012, 06:37:17 am by MarkGrieveson »
I am using VL7.0 standard with XFCE

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: issues with last upgrade after install of VL-7.0
« Reply #1 on: March 15, 2012, 11:48:48 pm »

Code: [Select]
Packages with unmet dependencies:
gegl: Depends: ffmpeg >= 0.10
Packages excluded:
gegl 0.1.8-i586-1vl70
gimp 2.7.3-i586-1vl70

Regarding the gegl error above, I think it's due to an incorrect setting in ffmpeg's dependencies (the stable version of 0.6-i586-1vl70).  When I try to install ffmpeg, it reports that there is a missing dependency:  "ffmpeg: Depends: libva >= 1.0.3".  However, the listing for libva in the stable source (extra) is version 0.32.0_1+sds2-i586-1vl70.  1.03 seems quite a bit higher than 0.32.   So perhaps there's an error here.
I am using VL7.0 standard with XFCE

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: issues with last upgrade after install of VL-7.0
« Reply #2 on: March 16, 2012, 04:19:39 am »
Thanks.  I'm on a nine day stretch at work, but will follow up on this.
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

Clinton_W

  • Member
  • *
  • Posts: 5
Re: issues with last upgrade after install of VL-7.0
« Reply #3 on: March 30, 2012, 12:39:59 am »
Regarding Inkscape might I add that I also did the update,and found that Inkscape no longer starts. I tried re-installing and receive an error message that "Excluding Inkscape due to dependency failure. inkscape: Depends: popt >= 1.14. " I do see a popt-1.7 listed in my search results. I also re-installed this just to be safe. This didn't change anything.

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: issues with last upgrade after install of VL-7.0
« Reply #4 on: March 30, 2012, 04:23:17 pm »
Regarding Inkscape might I add that I also did the update,and found that Inkscape no longer starts. I tried re-installing and receive an error message that "Excluding Inkscape due to dependency failure. inkscape: Depends: popt >= 1.14. " I do see a popt-1.7 listed in my search results. I also re-installed this just to be safe. This didn't change anything.
Hello.  I did manage to get inkscape working again, so perhaps you could too.  See the first post in this thread, and also see http://forum.vectorlinux.com/index.php?topic=15913.0 -- specifically the last couple of posts there.
I am using VL7.0 standard with XFCE