Please support VectorLinux!

Author Topic: are there easier ways to start pppoe internet connection  (Read 2181 times)

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
are there easier ways to start pppoe internet connection
« on: March 12, 2012, 04:02:54 pm »
Hello.  I have an ADSL modem/router, and I use pppoe.  I set up the connection via pppoe-setup.  So, now whenever I wish to connect, I have been logging in as root in the terminal, and running pppoe-start.  Is there an easier way to connect that doesn't involve logging in as root?  I see the wicd applet in the top panel, but I can't figure out how to set it up for my pppoe connection.  Anyway, if this or something else can be used, then do please let me know.
I am using VL7.0 standard with XFCE

vincent2

  • Vectorite
  • ***
  • Posts: 412
Re: are there easier ways to start pppoe internet connection
« Reply #1 on: March 12, 2012, 06:34:35 pm »
Bonjour!

please pulg in cable to your laptop or/desktop with modem/router,in opera typing 192.168.1.1/or 192.168.0.1, user:admin, password:admin,once enter router/modem admin interface, go to wan configure, enter your adsl pppoe user name and password, set it connect automatically,also enabling DHCP server there, then save the config....wait 10-20 sec. you'll be on internet automatically,

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: are there easier ways to start pppoe internet connection
« Reply #2 on: March 12, 2012, 07:49:47 pm »
Thanks for the suggestion.  Tried it but it didn't work.  It just said "Connecting..." forever.

I'm wondering too if there is a program/applet that will report the connection speed to me.  I tried one on Cairo-dock, but it wasn't that good.
I am using VL7.0 standard with XFCE

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: are there easier ways to start pppoe internet connection
« Reply #3 on: March 13, 2012, 12:57:50 pm »
MarkFrieveson,

What brand/model is your ADSL modem/router?

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: are there easier ways to start pppoe internet connection
« Reply #4 on: March 13, 2012, 04:17:06 pm »
It's an old one.  It's an OvisLink ADSL modem/router, model number OV711C.
I am using VL7.0 standard with XFCE

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: are there easier ways to start pppoe internet connection
« Reply #5 on: March 13, 2012, 05:26:23 pm »
It's an old one.  It's an OvisLink ADSL modem/router, model number OV711C.

Pls refer to the manual to configure auto dialing

http://www.ovislink.com/newovislink/Products/DSL_CABLEs/OV711C/OV711C_man.pdf

bigpaws

  • Vectorian
  • ****
  • Posts: 1868
Re: are there easier ways to start pppoe internet connection
« Reply #6 on: March 13, 2012, 09:59:59 pm »
Here is a post I found on how to get pppoe-start to
work as  a normal user.

http://www.linuxquestions.org/questions/slackware-14/pppoe-start-as-user-368226/

HTH

Bigpaws

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: are there easier ways to start pppoe internet connection
« Reply #7 on: March 14, 2012, 06:14:39 am »
Thanks for the link on using sudo to address the issue.  Admittedly, I'd rather not have to screw around with the sudoers file.  I had thought that wicd already did that, but I guess not.

Speaking of wicd, it now sometimes will announce that a connection has been established.  Yet, when I open Firefox, I'm told that I'm not connected to the Internet.  It seems I'm only truly connected when I use the pppoe-start as root command.  Also, even if I press wicd's disconnect button, I'll still be connected if I had done so previously with pppoe-start.  wicd just seems to be on its own little planet.
« Last Edit: March 14, 2012, 06:16:43 am by MarkGrieveson »
I am using VL7.0 standard with XFCE