VectorLinux
July 22, 2014, 07:06:37 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: [solved] gscan2pdf  (Read 2493 times)
MarkGrieveson
Vectorian
****
Posts: 531


« on: March 13, 2012, 07:32:07 pm »

One program I'd really like to see here is gscan2pdf.  It produces PDFs or DjVus from scanned documents.  Very handy.  It can also be a replacement for xsane, with some decent OCR abilities.  The source is at http://sourceforge.net/projects/gscan2pdf/files/.
« Last Edit: June 17, 2012, 09:46:33 pm by MarkGrieveson » Logged

I am using VL7.0 standard with XFCE
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #1 on: April 14, 2012, 08:29:58 am »

Has there been any progress with this request?  One reason I really like the program gscan2pdf is that pdf files with multiple pages can be created from multiple scanned images.  So, if I scan a four page document, I create one image per page (four images in total) which I can then merge into one pdf file with gscan2pdf.  I haven't found a way to do this with xsane.

I have tried to install gscan2pdf from source, but it won't work for some reason.  I also tried to use vpackager on the source, but it fails.
Logged

I am using VL7.0 standard with XFCE
bigpaws
Vectorian
****
Posts: 1843


« Reply #2 on: April 14, 2012, 01:22:47 pm »

xsane mulitpage project, then enter how any pages.

Bigpaws
Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #3 on: April 26, 2012, 02:39:50 pm »

xsane mulitpage project, then enter how any pages.

Bigpaws
Thanks for the suggestion.  I looked at xsane, but I couldn't find the option of "multipage project".

Logged

I am using VL7.0 standard with XFCE
bigpaws
Vectorian
****
Posts: 1843


« Reply #4 on: April 26, 2012, 10:02:48 pm »

http://www.xsane.org/doc/sane-xsane-multipage-doc.html

Bigpaws
Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #5 on: April 27, 2012, 06:03:19 am »


Thanks, I'll give that a try.  I still would really like to have gscan2pdf available, though.
Logged

I am using VL7.0 standard with XFCE
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #6 on: May 04, 2012, 09:16:31 am »

MarkGrieveson,

I have build gscan2pdf but it need newer imagemagick as dependency. As far as I know upgrading imagemagick may break other stuff. I will try to ignore new imagemagick first. Once it is ready I will let you know. Smiley
Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #7 on: May 14, 2012, 07:24:20 am »

Thanks for doing that.  Version 1.0.4-i586-1vl70 is working well, though the help browser still doesn't work, but I'll keep updating and following the progress.

Again, much appreciated.
Logged

I am using VL7.0 standard with XFCE
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #8 on: May 14, 2012, 09:16:44 pm »

what wrong with the help option?
Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #9 on: June 06, 2012, 05:20:41 am »

what wrong with the help option?

Quote from: gscan2pdf program
The help viewer requires module Gtk2::Ex::PodViewer
Alternatively, try: gscan2pdf --help
Logged

I am using VL7.0 standard with XFCE
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #10 on: June 06, 2012, 07:10:56 am »

what wrong with the help option?

Quote from: gscan2pdf program
The help viewer requires module Gtk2::Ex::PodViewer
Alternatively, try: gscan2pdf --help

try install perl-gtk2-ex-podviewer-0.18-i586-1vl70.txz from http://vectorlinux.osuosl.org/veclinux-7.0/extra/ repository via gslapt/slapt-get
Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #11 on: June 06, 2012, 01:21:00 pm »

Thanks hata_ph.  It works now.
Logged

I am using VL7.0 standard with XFCE
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #12 on: June 08, 2012, 11:11:03 am »

Actually, while the program installed and opened successfully, it didn't actually work when I tried to save a couple of image files to a pdf file (specifically, pnm to pdf).  It did work with scanning images, but saving into pdf failed.  It just seemed to stall, and never make the conversion (I could cancel the job, so it didn't freeze).

I found a file on slackfind.net, which was gscan2pdf-1.0.0-i686-1jsc.txz, and this is working for me.  So gscan2pdf can work.  But it seems only version 1.0.0.

Anyway, my apologies for initially reporting that the version 1.0.4 package that you did was fully working. 
Logged

I am using VL7.0 standard with XFCE
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #13 on: June 14, 2012, 06:08:02 pm »

MarkGrieveson

I have build gscan2pdf-1.0.4 version 3 in http://vlcore.vectorlinux.com/pkg/untested/, can u have a test on it? I test with jpg to pdf and it is working for me...
Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #14 on: June 17, 2012, 11:37:52 am »

Nuts!  I accidentally upgraded the entire system to testing, rather than just installing gscan2pdf.  From previous experience, I loathe using testing versions of an OS.  Is there a way I can downgrade to stable?

But I digress.  Anyway, I now get the following feedback when I try to use gscan2pdf:

Code:
mark:$ gscan2pdf
Can't locate Glib.pm in @INC (@INC contains: /usr/lib/perl5/vendor_perl/5.12.3/i486-linux-thread-multi/ /usr/lib/perl5/site_perl/5.16.0/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.16.0 /usr/lib/perl5/vendor_perl/5.16.0/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.16.0 /usr/lib/perl5/5.16.0/i586-linux-thread-multi /usr/lib/perl5/5.16.0 /usr/lib/perl5/site_perl/5.12.3 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.12.3 /usr/lib/perl5/vendor_perl .) at /usr/lib/perl5/site_perl/5.12.3/Gscan2pdf.pm line 11.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.12.3/Gscan2pdf.pm line 11.
Compilation failed in require at /usr/bin/gscan2pdf line 127.
BEGIN failed--compilation aborted at /usr/bin/gscan2pdf line 127.
Logged

I am using VL7.0 standard with XFCE
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!