VectorLinux
October 23, 2014, 11:30:51 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: installation failure  (Read 1122 times)
rkonrad
Member
*
Posts: 71


« on: March 25, 2012, 08:37:28 pm »

Hi,

I'm new here.  I'm not a newbie nor do I consider myself an advanced linux user.  I have, however, installed at least a dozen linux distros on my system but here I am stumped. 

I've followed the installation procedures for VL 7 gold.  I'm using my usb external hard drive sdb1 for the installation with one partition mounted to "/" and also have a valid swap on sdb2.  I've chosen grub to go on the main boot record on my internal hard drive sda.  When I reboot, the vector linux splash screen hangs with the progress bar frozen.  What other information can I give you?  I was thinking my usb drive might be having trouble but perhaps others have experienced the same?

Richard
Logged
rkonrad
Member
*
Posts: 71


« Reply #1 on: April 01, 2012, 07:21:18 pm »

Here is some more data:

I just bought a new usb hard drive (1.5 tb).  Once again, grub is installed on my MBR which is my internal hd (hda).  I checked for bad blocks on that drive and all is ok.  After a fresh installation, the results are the same.  So I loaded the cd and booted directly to the installation "root=/dev/sdb3 ro" (or something like that) and I got the following message(s)

Cannot open root device sdb3 or unknown block (0,0)...... kernel panic

Any thoughts??  I'm really stumped.
Logged
rkonrad
Member
*
Posts: 71


« Reply #2 on: April 01, 2012, 08:47:44 pm »

Ok.  It seems the kernel is loading faster than my usb hard drive can be recognized so I added "rootdelay=10" at the prompt. It worked!  Question is:  how can i make this permanent?  I'm assuming that should be entered into a grub file - but which one?  Thanks in advance.

Richard
Logged
pierce.jason
Packager
Vectorite
****
Posts: 250



« Reply #3 on: April 02, 2012, 03:48:04 pm »

Good question there about grub rkonrad!

I could tell you how to hack it into place, but my method of dealing with grub really isn't ideal Wink

There's a file somewhere in etc that you should place this in. That way it will be put back into place any time the grub menu is updated.

If you don't get a good answer here, then mark this thread as solved and open a new one about adding boot options to grub Wink
Logged

pierce.jason
Email: $(echo -e "moc\x2eliamg\x40nosaj.ecreip" | rev)
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!