March 30, 2015, 05:44:46 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
Author Topic: Startup in VL 7 for CUPS and GKrellm2 (Solved)  (Read 1017 times)
Posts: 13

« on: March 28, 2012, 08:17:18 am »

Hi, I'm trying to get CUPS and GKrellm2 to launch at boot.
I edited ./.fluxbox/startup as follows:

# fluxbox startup-script:
# Lines starting with a '#' are ignored.

# Change your keymap:
xmodmap "~/.Xmodmap"

# Applications you want to run with fluxbox.
# unclutter -idle 2 &
# wmnd &
# wmsmixer -w &
# idesk &

# And last but not least we start fluxbox.
# Because it is the last app you have to run it with ''exec'' before it.
cups &
gkrellm2 &
exec fluxbox
# or if you want to keep a log:
# exec fluxbox -log "~/.fluxbox/log"

Any insight into what I'm doing wrong is much appreciated, thanks.
« Last Edit: March 29, 2012, 02:48:18 pm by wmichaelb » Logged
Posts: 3202

« Reply #1 on: March 28, 2012, 09:08:39 am »

For CUPS, use vasm -> Services to add it to your init level 4.  That will start it at boot.

For gkrellm2, that should be fine

Posts: 3780

« Reply #2 on: March 28, 2012, 11:10:31 am »

Just an fyi.
There is a tutorial link on the desktop to Vector-Tutorials.

You can use the search box on the right, that says "Search Keywords" inside of it.
Try searching "Auto Start", "Gkrellm", "vasm"
You will find something for each of those topics.

Here is a couple I'd recommend.
Customizing Grellm
  This is an older style tutorial.
Introduction to vasm and sneek peek at the new vasm

Vectorlinux screencasts and  tutorials can be found at....
Posts: 13

« Reply #3 on: March 29, 2012, 02:45:20 pm »

So...editing /home/myname/.fluxbox/startup as noted above did not work. I copied the startup file into a test file, and ran it as a shell, but neither it nor I could find the executable for GKrellM2. I'm not sure why.

One of the videos on an older version of Vector instructed one to go to Menu->Settings->Startup.
The similar path in V 7.0 is Menu->Applications->Settings->Session and Startup. The appropriate command for GKrellM2 is the same as that for GKrellM, i.e, gkrellm (gkrellm2 won't work). Adding that to the list via this menu worked. I logged out and back in and voila! GkrellM2.

I originally configured CUPS by going to Menu->Applications->System->Configure Printing. When I first tried to open it, it wouldn't open the CUPS admin window. I tried the same as root, but to no avail. It finally  dawned on me to restart CUPS (etc/init.d/cups restart), and then it worked. So I needed to get that to happen automagically on boot.

I got CUPS to start by going to Menu->Applications->System->vasm->Super->SRVSET->Graphical User Interface Desktop, and then clicking on the button for CUPS for run level 4. I then exited all the way out, logged out and back in, and printing now works at startup for everything.

The tutorials are excellent if one translates to the newer menus in 7.0. Right now, my system is largely doing what I want and I'm a happy camper.

Now, if I could just install Clementine...

Thanks to all for your help!
« Last Edit: March 29, 2012, 02:47:53 pm by wmichaelb » Logged
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!