VectorLinux
October 31, 2014, 11:43:40 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 [2] 3 4 ... 6
  Print  
Author Topic: digikam for VL7  (Read 11020 times)
rkonrad
Member
*
Posts: 71


« Reply #15 on: August 14, 2012, 10:40:31 am »

Perhaps I need to downgrade something?  Let me know your thoughts when you have some time.

Richard
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #16 on: August 14, 2012, 11:10:33 am »

libavcodec.so is part of ffmpeg.
I would make the symlinks if I were you.
digikam should be rebuilt against the ffmpeg in testing though
Logged
rkonrad
Member
*
Posts: 71


« Reply #17 on: August 14, 2012, 11:58:10 am »

I ended up having to make a whole wack of symlinks including libavcodec, libavformat, libavutil and libswscale. (downgrading).  Now that is finished, this is what I get:


root:# digikam
digikam: /usr/lib/libavutil.so.50: version `LIBAVUTIL_50' not found (required by /usr/lib/libopencv_highgui.so.2.4)
digikam: /usr/lib/libavformat.so.52: version `LIBAVFORMAT_52' not found (required by /usr/lib/libopencv_highgui.so.2.4)
digikam: /usr/lib/libavcodec.so.52: version `LIBAVCODEC_52' not found (required by /usr/lib/libopencv_highgui.so.2.4)
digikam: /usr/lib/libswscale.so.0: version `LIBSWSCALE_0' not found (required by /usr/lib/libopencv_highgui.so.2.4)

Thanks

Richard
Logged
rkonrad
Member
*
Posts: 71


« Reply #18 on: August 14, 2012, 12:01:40 pm »

The exact version of my ffmpeg is 0.10-i586-5vl70.
Logged
sledgehammer
Vectorian
****
Posts: 1425



« Reply #19 on: August 14, 2012, 02:28:19 pm »

I get the same error.

Logged

VL7.0 xfce4 Samsung RF511
rkonrad
Member
*
Posts: 71


« Reply #20 on: August 14, 2012, 04:11:32 pm »

What is your opinion hata_ph?  Should this be rebuilt?  Sorry if I seem impatient Lips sealed  Thanks for your help so far.

Richard
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #21 on: August 14, 2012, 05:23:58 pm »

I rebuilt it. you can find it here: http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/digikam-2.7.0-i586-3vl70.txz
you will need this also: http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/opencv-2.4.2-i586-1vl70.txz

let me know if it asks for more
Logged
hata_ph
Packager
Vectorian
****
Posts: 3258


-- Just being myself --


« Reply #22 on: August 14, 2012, 07:34:45 pm »

I install digikam-2.7.0-i586-2vl70 via gslapt in a new VL7 GOLD vm and i can open it with out any libavcodec error...
Logged
sledgehammer
Vectorian
****
Posts: 1425



« Reply #23 on: August 15, 2012, 12:23:33 pm »

uelsk8s

I installed your two packages but still get following error:

Quote
digikam: error while loading shared libraries: libkipi.so.9: cannot open shared object file: No such file or directory

Both programs showed a lot of (blank) "is not a symbolic link" in terminal following install. 

I'm just sort of curious about digikam.  Have never used it, but I think I read somewhere that google is no longer supporting Picasa?
Logged

VL7.0 xfce4 Samsung RF511
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #24 on: August 15, 2012, 02:19:21 pm »

digikan looked pretty good to me, but I didn't use it much just started it.
I had to install all these pkgs from untested to get it to run.
digikam
glibc
kdelibs
kdepimlibs
libkdcraw
libkexiv2
libkipi
marble
opencv
Logged
hata_ph
Packager
Vectorian
****
Posts: 3258


-- Just being myself --


« Reply #25 on: August 15, 2012, 06:56:19 pm »

rkonrad,

Can you try to install digikam on a new system just for testing?
Logged
sledgehammer
Vectorian
****
Posts: 1425



« Reply #26 on: August 15, 2012, 08:17:44 pm »

uelsk8s,

I have all those programs loaded from the testing repository, plus your two later versions of digikam and opencv but still get the same error.  I do not have the unstable repository enabled.

John
Logged

VL7.0 xfce4 Samsung RF511
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #27 on: August 16, 2012, 05:16:31 am »

uelsk8s,

I have all those programs loaded from the testing repository, plus your two later versions of digikam and opencv but still get the same error.  I do not have the unstable repository enabled.

John
John,
you would have to upgrade all those pkgs from the untested repo to get it working.
I would recommend you wait until it is rebuilt.

Uelsk8s
Logged
sledgehammer
Vectorian
****
Posts: 1425



« Reply #28 on: August 16, 2012, 05:39:49 am »

Uelsk8s

Thanks for the tip.  I'l take it.

John
Logged

VL7.0 xfce4 Samsung RF511
rkonrad
Member
*
Posts: 71


« Reply #29 on: August 16, 2012, 06:31:13 am »

I get the same error message "digikam: error while loading shared libraries: libkipi.so.9: cannot open shared object file: No such file or directory"  I"m afraid I don't know what you mean hata_ph, by "
Can you try to install digikam on a new system just for testing?"  If you're meaning a fresh installation, I have only my computer. Thanks.
Logged
Pages: 1 [2] 3 4 ... 6
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!