VectorLinux
October 30, 2014, 09:17:44 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [SOLVED] Kompozer suddenly terminates, anyone else using it?  (Read 4070 times)
benali
Member
*
Posts: 23


« on: April 04, 2012, 06:48:17 am »

Kompozer 0.7.10 disappears under certain conditions under Vector Std 7.0.  By "disappears" I mean that the panel instantly disappears without warning and the 2 Kompozer processes immediately terminate.

This happens if you --

1. pick View  from the top menu then Show/Hide (or Text Zoom or Character Encoding)
2. pick File  from the top menu then Recent Pages
3. there may be other cases I haven't discovered yet

The install of Kompozer went fine according to Gslapt's completion message but I haven't checked any logs.

Anybody else using Kompozer? These issues make it pretty hard to use the product.

Thank you.

« Last Edit: April 04, 2012, 08:26:16 am by benali » Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #1 on: April 04, 2012, 07:29:35 am »

KompoZer 0.7.10 is not compatible with GTK ≥ 2.14, so it is obsolete for VL7. The latest is 0.8b3, from March 2010, so development is pretty much stalled, if not stopped. Everyone is still hoping for the promised day when kompozer code is merged back to SeaMonkey Composer... Roll Eyes
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
benali
Member
*
Posts: 23


« Reply #2 on: April 04, 2012, 07:38:10 am »

Oh ok, thank you. I had loaded Kompozer from the V7 repository so I thought that meant it was compatible with V7.

Any suggestions on which HTML editor I can use instead? I've got Bluefish but it doesn't appear to support a "text editor" view (it always shows the HTML tags which I don't want to see).

Thank you!
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #3 on: April 04, 2012, 08:00:14 am »

Try Bluegriffon.  We have version 1.4 in the repository, but I see version 1.4.1 is out now.
You can read about it here
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
benali
Member
*
Posts: 23


« Reply #4 on: April 04, 2012, 08:16:31 am »

Hey, great,  I downloaded Bluegriffon and it works fine. It has both the WYSIWYG and HTML Source buttons, which is what I need.

Thank you!
Logged
benali
Member
*
Posts: 23


« Reply #5 on: April 04, 2012, 09:41:26 pm »

BTW, I see both versions of Bluegriffon in the repository right now.

1.4 works great, 1.4.1 does NOT work at all. You launch it and it fails immediately.

This is with VectorLinux Standard Edition 7.0.

Thank you.
Logged
Lyn
Vectorian
****
Posts: 651



« Reply #6 on: April 04, 2012, 11:49:20 pm »

interestingly enough the source button is greyed out in 1.4
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #7 on: April 05, 2012, 03:35:38 am »

Tested Bluegriffon 1.4.1 get the folllowing when ran from terminal.
/opt/bluegriffon/bluegriffon-bin: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/bluegriffon/libxul.so)

I am going to remove 1.4.1 from repo's until another build can be made.

Thanks for testing and quick feedback.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
hata_ph
Packager
Vectorian
****
Posts: 3258


-- Just being myself --


« Reply #8 on: April 09, 2012, 08:59:25 pm »

Tested Bluegriffon 1.4.1 get the folllowing when ran from terminal.
/opt/bluegriffon/bluegriffon-bin: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/bluegriffon/libxul.so)

I am going to remove 1.4.1 from repo's until another build can be made.

Thanks for testing and quick feedback.

Bluegriffon-1.4.1 need gcc > 4.6.x to run. Currently VL7 is using gcc-4.5.2 which will cause error...

http://www.linuxquestions.org/questions/slackware-14/usr-lib64-libstdc-so-6-version-%60glibcxx_3-4-15-not-found-919350/
http://stackoverflow.com/questions/5216399/usr-lib-libstdc-so-6-version-glibcxx-3-4-15-not-found
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!