VectorLinux
April 18, 2014, 02:33:53 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: sound not working in kdegames  (Read 695 times)
MarkGrieveson
Vectorian
****
Posts: 531


« on: April 23, 2012, 06:48:55 am »

Hello.  I installed kdegames 4.8.1-i586-1vl70 within Vector Linux 7.0, and the sound does not work in them (IE, kolf or kbattleship).  I did choose to have sounds enabled when playing these games, but I hear nothing.  Sound works in other games, such as pySolitaire, pokerTH or dopewars, but not the kde games.
Logged

I am using VL7.0 standard with XFCE
hata_ph
Packager
Vectorian
****
Posts: 3206


-- Just being myself --


« Reply #1 on: April 23, 2012, 04:27:54 pm »

try run the game from konsole or terminal and see is there any error message...
Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #2 on: April 24, 2012, 10:51:03 am »

Code:
vector:/~
mark:$ kbattleship
kbattleship(13437)/kdeui (KIconLoader): Error: standard icon theme "oxygen" not found!

Could not resolve property : #XMLID_78_
Could not resolve property : #XMLID_79_
Could not resolve property : #XMLID_82_
Could not resolve property : #XMLID_83_
Could not resolve property : #XMLID_89_
Could not resolve property : #XMLID_90_
Could not resolve property : #XMLID_91_
Could not resolve property : #XMLID_92_
Could not resolve property : #XMLID_98_
Could not resolve property : #XMLID_99_
Could not resolve property : #XMLID_100_
Could not resolve property : #XMLID_101_
Could not resolve property : #XMLID_102_
Could not resolve property : #XMLID_103_
Could not resolve property : #XMLID_104_
Could not resolve property : #XMLID_105_
Could not resolve property : #XMLID_106_
Could not resolve property : #XMLID_107_
Could not resolve property : #XMLID_108_
Could not resolve property : #XMLID_109_
Could not resolve property : #XMLID_110_
Could not resolve property : #XMLID_111_
Could not resolve property : #XMLID_112_
Could not resolve property : #XMLID_113_
Could not resolve property : #XMLID_114_
Could not resolve property : #XMLID_115_
Could not resolve property : #XMLID_116_
Could not resolve property : #XMLID_117_
Could not resolve property : #XMLID_118_
Could not resolve property : #XMLID_119_
Could not resolve property : #XMLID_120_
Could not resolve property : #XMLID_121_
Could not resolve property : #XMLID_122_
Could not resolve property : #XMLID_123_
Could not resolve property : #XMLID_124_
Could not resolve property : #XMLID_125_
Could not resolve property : #XMLID_126_
Could not resolve property : #XMLID_127_
Could not resolve property : #XMLID_129_
Could not resolve property : #XMLID_130_
Could not resolve property : #XMLID_131_
Could not resolve property : #XMLID_132_
Could not resolve property : #XMLID_133_
Could not resolve property : #XMLID_134_
Could not resolve property : #XMLID_135_
Could not resolve property : #XMLID_136_
Could not resolve property : #XMLID_137_
Could not resolve property : #XMLID_138_
Could not resolve property : #XMLID_139_
Could not resolve property : #XMLID_140_
Could not resolve property : #XMLID_141_
Could not resolve property : #XMLID_142_
Could not resolve property : #XMLID_143_
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
kbattleship(13437)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
kbattleship(13437)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
vector:/~
mark:$
Logged

I am using VL7.0 standard with XFCE
hata_ph
Packager
Vectorian
****
Posts: 3206


-- Just being myself --


« Reply #3 on: April 26, 2012, 09:23:49 pm »

do u have phonon-backend-xine installed?
Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #4 on: April 27, 2012, 05:28:55 am »

do u have phonon-backend-xine installed?
Thanks, I did install that and it did give kbattleship sound.  As well, kapman and kpatience now has sound.  However, other games of the kdegames set, such as bomber or kolf or kblocks, still do not have sound.
Code:
vector:/~
mark:$ kolf
kolf(9120)/kdeui (KIconLoader): Error: standard icon theme "oxygen" not found!

kolf(9120): Couldn't start knotify from knotify4.desktop:  "Could not find service 'knotify4.desktop'."

kolf(9120)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "The name org.kde.knotify was not provided by any .service files"
vector:/~
mark:$
Code:
vector:/~
mark:$ bomber
bomber(9124)/kdeui (KIconLoader): Error: standard icon theme "oxygen" not found!

link g4310 hasn't been detected!
link g4300 hasn't been detected!
link g4300 hasn't been detected!
link g4300 hasn't been detected!
link g4310 hasn't been detected!
Couldn't find node plane_1. Skipping rendering.
vector:/~
mark:$
Code:
vector:/~
mark:$ kblocks
kblocks(9245)/kdeui (KIconLoader): Error: standard icon theme "oxygen" not found!

kblocks(9245)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
vector:/~
mark:$
« Last Edit: April 27, 2012, 05:46:33 am by MarkGrieveson » Logged

I am using VL7.0 standard with XFCE
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!