VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: alsa problem  (Read 1102 times)

linuxnews

  • Member
  • *
  • Posts: 2
alsa problem
« on: April 21, 2012, 05:51:57 am »

Hi, I can't get alsa working in vector linux light 7.0
My card is realtek ALC889A (snd_hda_intel) . Alsa detected it but the "headphone" option is 00 and I can't change it  ( in alsamixer )
Seems the same problem as here : http://www.linuxquestions.org/questions/linux-newbie-8/no-headphone-control-in-alsamixer-797063/
A solution ?
Or maybe I can try this ?



"You are right, it's not seeing your Headphone.
"See:
http://linux.derkeiler.com/Mailing-L.../msg00061.html
Quote:
Some users with specific hda-intel cards have
reported problems with sound card detection in the 2.6.25 series of linux kernels.
See:
http://linux.derkeiler.com/Mailing-L.../msg00001.html

So maybe you need to pass some options to the snd_hda_intel module
Eg
Add the line

options snd_hda_intel model=asus

to your /etc/modprobe.conf

and then rmmod and modprobe to reinstall the module, or just reboot.

Alternatively, maybe try a different (older, or newer) kernel from your distro's package manager.""

But I don't know how do it with this distribution because I'm newbie

Thank you
« Last Edit: April 21, 2012, 05:57:38 am by linuxnews »
Logged

zebedeeboss

  • Member
  • *
  • Posts: 5
Re: alsa problem
« Reply #1 on: April 21, 2012, 09:44:44 am »

Hi, I can't get alsa working in vector linux light 7.0
My card is realtek ALC889A (snd_hda_intel) . Alsa detected it but the "headphone" option is 00 and I can't change it  ( in alsamixer )
Seems the same problem as here : http://www.linuxquestions.org/questions/linux-newbie-8/no-headphone-control-in-alsamixer-797063/
A solution ?

Only a Newb myself but did you check alsamixer out in a terminal session?

In terminal keep arrowing right for further options off screen.  Also make sure you choose the right settings "F6" before you start altering.

Using this method I got my card using all 6 channels - my card is Card: HDA Intel PCH    Chip: Realtek ALC662 rev1

Hope this helps
Logged
64bit vector linux  Brought to you by Vector-Linux  Linux Version 3.2.13
Compiled #1 SMP Tue Mar 27 13:47:37 MDT 2012  Four 3GHz Intel i5 Processors, 6GB RAM  23943 Bogomips Total

fogpipe

  • Vectorite
  • ***
  • Posts: 105
Re: alsa problem
« Reply #2 on: April 29, 2012, 06:17:59 am »

What seemed to work for me with the onboard intel sound in my computer (alsa was not seeing it)  was putting
Quote
modprobe snd-hda-intel
in /etc/rc.d/rc.local and
Quote
options snd-hda-intel model=auto
in /etc/modprobe.d/sound.conf
VL 7.0 on a Dell Optiplex 745


Which, just to give credit where its due, i think i got from the ubuntu forums.
« Last Edit: April 29, 2012, 09:00:47 am by fogpipe »
Logged