VectorLinux
October 25, 2014, 06:48:22 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Changing resolution on VL7 STD stuck at 60hz and 1024x768 (Solved)  (Read 2777 times)
fogpipe
Vectorite
***
Posts: 105


« on: April 28, 2012, 05:37:35 pm »

I need to be at 1280x1024 which i know this monitor and video hardware will do.

Here is my xorg.conf

Quote
Section "ServerFlags"
 Option  "AutoAddDevices" "False"
 Option  "AutoEnableDevices" "False"
EndSection

Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath   "/usr/lib/xorg/modules"
FontPath     "/usr/share/fonts/local"
FontPath     "/usr/share/fonts/TTF"
FontPath     "/usr/share/fonts/OTF"
FontPath     "/usr/share/fonts/Type1"
FontPath     "/usr/share/fonts/misc"
FontPath     "/usr/share/fonts/CID"
FontPath     "/usr/share/fonts/75dpi/:unscaled"
FontPath     "/usr/share/fonts/100dpi/:unscaled"
FontPath     "/usr/lib/X11/fonts/truetype/"
FontPath     "/usr/lib/X11/fonts/local/"
FontPath     "/usr/lib/X11/fonts/cyrillic/"
FontPath     "/usr/share/fonts/75dpi"
FontPath     "/usr/share/fonts/100dpi"
FontPath     "/usr/lib/X11/fonts/truetype/"
FontPath     "/usr/lib/X11/fonts/local/"
FontPath     "/usr/lib/X11/fonts/cyrillic/"
FontPath     "/usr/share/fonts/cyrillic"
EndSection

Section "Module"
Load  "record"
Load  "extmod"
Load  "dri2"
Load  "dri"
Load  "dbe"
Load  "glx"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option  "XkbLayout"  "us"    ## KEYBOARD_MAP!
Option  "XkbModel"  "pc104"    ## KEYBOARD_MODEL!
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option       "Protocol" "auto"
Option       "Device" "/dev/input/mice"
Option       "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Option "DPMS"
#DisplaySize 336 269 # 96 DPI @ 1280x1024 (non 4:3 aspect)
#Option "UseEdidFreqs" "1"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
HorizSync 30-86
VertRefresh 50-180
EndSection

Section "Device"
### Available Driver options are:-
### Values: : integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
### <percent>: "<f>%"
### [
arg]: arg optional
#Option     "DRI"                   # [<bool>]
#Option     "ColorKey"              #
#Option     "VideoKey"              #
#Option     "FallbackDebug"         # [
<bool>]
#Option     "Tiling"                # [<bool>]
#Option     "LinearFramebuffer"     # [<bool>]
#Option     "Shadow"                # [<bool>]
#Option     "SwapbuffersWait"       # [<bool>]
#Option     "TripleBuffer"          # [<bool>]
#Option     "XvMC"                  # [<bool>]
#Option     "XvPreferOverlay"       # [<bool>]
#Option     "DebugFlushBatches"     # [<bool>]
#Option     "DebugFlushCaches"      # [<bool>]
#Option     "DebugWait"             # [<bool>]
#Option     "HotPlug"               # [<bool>]
#Option     "RelaxedFencing"        # [<bool>]
Identifier  "Card0"
Driver      "intel"
BusID       "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
DefaultDepth 16
SubSection "Display"
Viewport   0 0
Depth     16
Modes "1280x1024"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "on"
EndSection

Thanks
« Last Edit: April 28, 2012, 09:02:42 pm by fogpipe » Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #1 on: April 28, 2012, 06:07:43 pm »

I had the same issue when I first installed Vector Linux 7.0.  The tool vasm was able to fix this.  vasm can be found under Menu/System/vasm (it can be found in the System section of the Menu).  After I used this tool to adjust it, I think I had to reboot, and then when I checked Menu/Settings/Display, I was able to change the resolution to 1084X768 (mine was stuck at 800X600).  I may have had to reboot here.  

I'm not sure exactly what option I chose under vasm, but it was not the default option (it was a reasonably evident choice though).  Sorry I can't be a little more specific.  It was a while ago that I installed VL7.0.  I'm sure vasm will allow you to increase your screen resolution though.
« Last Edit: April 28, 2012, 06:09:53 pm by MarkGrieveson » Logged

I am using VL7.0 standard with XFCE
fogpipe
Vectorite
***
Posts: 105


« Reply #2 on: April 28, 2012, 06:31:52 pm »

vasm didnt work.
Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #3 on: April 28, 2012, 06:50:48 pm »

Sorry to hear that.  I'm surprised, because after I ran it, it gave me the option to change the resolution from 800x600 to 1024x768 or 1280x1024, which were options that were previously unavailable to me.
Logged

I am using VL7.0 standard with XFCE
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #4 on: April 28, 2012, 06:55:39 pm »

Perhaps if you select SUPER first, and then XWINDOW, and then XCONF, and then VXCONF, then I think it may work.
Logged

I am using VL7.0 standard with XFCE
fogpipe
Vectorite
***
Posts: 105


« Reply #5 on: April 28, 2012, 07:34:43 pm »

I have exhausted the options vasm offers. Changing the resolution in vasm has no actual effect on the resolution when x actually runs after my attempts at vasm confg, no matter what i choose i still get 1024x768@60hz. As i said previously, i have tried vasm.
Logged
fogpipe
Vectorite
***
Posts: 105


« Reply #6 on: April 28, 2012, 09:02:01 pm »

Some experimentation with modelines did the trick. The last one yielded satisfactory results:
Quote
Section "Monitor"
Option "DPMS"
#DisplaySize 336 269 # 96 DPI @ 1280x1024 (non 4:3 aspect)
Option "UseEdidFreqs" "1"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
HorizSync 30-86
VertRefresh 50-180
#Modeline "1280x960" 129.75 1280 1312 1800 1832 960 979 990 1009
#Modeline "1280x960@75" 142.76 1280 1312 1848 1880 960 978 990 1009
#Modeline "1280x1024" 156.43 1280 1312 1904 1936 1024 1043 1056 1076
ModeLine "1280x1024" 135.0   1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
EndSection
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!