VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: need help with Java  (Read 908 times)

Joncho

  • Member
  • *
  • Posts: 45
need help with Java
« on: March 25, 2012, 03:12:54 pm »

Hello,

I've installed jdk-7u3 and jre-7u3 via gslapt but when i try to run any java program i get the following error:

Quote
java: error while loading shared libraries: libjli.so: cannot open shared object file: No such file or directory

What can i do? I'm trying to learn java and would like to do it with the most recent jdk.

I will thank any advice you can give me.
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: need help with Java
« Reply #1 on: March 25, 2012, 03:39:53 pm »

As root run
slocate -u

When it completes run this as regular user...
locate libjli.so

Post what you get as output.
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

Joncho

  • Member
  • *
  • Posts: 45
Re: need help with Java
« Reply #2 on: March 25, 2012, 04:02:05 pm »

Code: [Select]
$ locate libjli.so
/usr/lib/java/lib/i386/jli/libjli.so

And in an unrelated question. Does slocate -u do the same thing that updatedb?
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: need help with Java
« Reply #3 on: March 25, 2012, 04:09:52 pm »

Code: [Select]
$ locate libjli.so
/usr/lib/java/lib/i386/jli/libjli.so

And in an unrelated question. Does slocate -u do the same thing that updatedb?

Yes, there man pages are identical.
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

ooseven

  • Member
  • *
  • Posts: 20
Re: need help with Java
« Reply #4 on: May 29, 2012, 08:05:49 pm »

In vl7.0 std gold it is already installed. But I use this page to install it if need to:

http://sites.google.com/site/easylinuxtipsproject/java#TOC-Install-JRE-32-bit-

The left side is for 32 bit, and the right side is for 64 bit.